JTAGICE mkII Probleme

Do you have a question? Post it now! No Registration Necessary

Translate This Thread From German to

Threaded View
Hallo Gruppe,

ich habe mir fFC%r die Firma ein JTAGICE mkII zugelegt, um einen
ATmega324P zu debuggen. Leider schaffe ich es nicht eine Verbindung
zum Controller FC%ber das JTAG-Interface herzustellen. Probiert habe ich
es mit AVR Studio als auch mit IAR. Die Verbindung FC%ber ISP
funktioniert tadellos. Ich bin mit den Leitungen direkt an die PINS
gegangen. Es ist nichts nachgeschaltet.
Zu Beginn hat der JTAGICE mkII ein Software update ohne Fehlermeldung
durchgefFC%hrt (ich hoffe nicht das dies ein Fehler war). Soll ich das
GerE4%t als Defekt zurFC%ckschicken, oder liegt der Fehler bei mir?

GruDF% Mark

Re: JTAGICE mkII Probleme
Hallo Mark,

Quoted text here. Click to load it

Sind die config-bits richtig gesetzt? JTAG enabled?
(Ich hatte ein in etwa umgekehrtes Problem: IO-ports funktionierten
nicht richtig, da JTAG eingeschaltet war).

Grüße,
Stefan

Re: JTAGICE mkII Probleme
Quoted text here. Click to load it

Hallo Stefan,

ja JTAG ist enable, aber wie es aussieht kommt die Kommunikation nicht
zustande. Bei AVR Studio wird mir empfohlen die ISP-Frequenz
anzupassen, aber ich habe schon alle Einstellungen ausprobiert und
beim IAR wird jedesmal eine andere Device-Adresse ausgelesen.

GruDF% Mark

Re: JTAGICE mkII Probleme
Mark Kreso schrieb:
Quoted text here. Click to load it
Also 2 Anschlußstecker?
Einen für Jtag und einen für ISP?

  Ich bin mit den Leitungen direkt an die PINS

wie lang sind die Leitungen?
Quoted text here. Click to load it
Wenn dann bricht der mit Fehlermeldung ab, und dann würde auch ISP
nicht mehr funzen!!
  Soll ich das
Quoted text here. Click to load it

Weil ISP geht würde ich eher den Fehler bei dir suchen.


Update vom AVR Studio aufgespielt, oder von CD ?
Leitungen zu lang?
Windows Vista?
Zwischen den eltungen keine Masseleitungen?
Spannung ok?

Mein Favori -> Leitungen sind vertauscht.


Andreas

Re: JTAGICE mkII Probleme
Hallo Andreas,

ich befFC%rchte auch das der Fehler bei mir liegt.

Quoted text here. Click to load it

Ich habe nur einen Stecker fFC%r ISP mit Leitungen von etwa 20cm. Von
dem greife ich lediglich VCC und GND (und RESET, aber den habe ich
mitlerweile nicht mehr angeschlossen) ab. Die anderen vier
Anschlusstecker sin ca 0,5cm vom QFN-GehE4%use entfernt angeschlossen.

Quoted text here. Click to load it

AVR Studio 4.12.498  Service Pack 4

Quoted text here. Click to load it

s.o.


XP


s.o.


Coltroller arbeitet mit 3,3V und einen Rippel von 20mV im 150kHz-
Bereich

Quoted text here. Click to load it

kenn ich, hab sie aber mindestens in Summe 6mal kontrolliert, sicher
ist sicher ;-))

GruDF% Mark


Re: JTAGICE mkII Probleme
Beliebte Fehler sind:
Der MKII-Stecker ist bei gleicher Pinzahl elektrisch nicht kompatibel
mit den 10poligen ISP-Stecker vom STK 500 - aber ich denke das weisst Du.
Einweitere häufiger Fehler ist die Verwechslung von Vref und Vcc.
Wenn ich es richtig im Kopf habe muss Vref mit dem Vcc vom uC verbunden
sein damit der MKII weiss welche Spannung anliegt.

Ob Du jetzt auf Reset verzichten kannst bin ich mir nicht ganz sicher.
Wenn Du ihn verwendest solltest Du auch darauf achten dass er auf Deinem
Entwicklungsboard nicht aktiv auf "High" gezogen wird wenn kein Reset
vorliegt.

Gerald

Re: JTAGICE mkII Probleme
Quoted text here. Click to load it

Hallo Gerald,
hab ich nochmal kontrolliert, aber leider war dort hier kein Fehler.
Den Reset Pin hab ich auch schon abgelF6%tet und direkt angeschlossen.

GruDF% Mark

Re: JTAGICE mkII Probleme
Mark Kreso schrieb:
Quoted text here. Click to load it
Hallo Mark,

hast Du den Controller schon mal getauscht?
Manchmal bekommt man die ungewollt in einen Zustand wo man mit dem
vorhanden Programmiergerät nicht mehr weiter kommt - manchmal z.B. zu
beheben im Paralleprogrammiermode...

Gruss
Gerald

Re: JTAGICE mkII Probleme
Quoted text here. Click to load it

Hallo Gerald,

ich habe es an zwei Controllern getestet, leider habe ich keine
MF6%glichkeit zum parallel programmieren. Aber ich bin schon am
FC%berlegen ob ein Evolution-Kit nicht doch Sinn macht. Eigentlich
wollte ich alles in der bestehenden Schaltung testen.

GruDF% Mark

Site Timeline