Labornetzteil

Do you have a question? Post it now! No Registration Necessary

Translate This Thread From German to

Threaded View

--------------42FB8CD09EF5332C58333693
Content-Type: text/plain; charset=iso-8859-1
Content-Transfer-Encoding: 8bit

Hallo!

Ich habe folgendes Labornetzteil heute aufgebaut:
http://ourworld.compuserve.com/homepages/Bill_Bowden/ps6.gif

Nur das ich den LM1458 durch einen LM358 ersetzt habe, sollte doch kein
Problem sein, oder? Den 2N3053 habe ich (weil ich ihn leider übersehen
habe :-() durch einen BC140 ersetzt. Aber die Schaltung gibt entweder 0V
aus oder sie beginnt (bei voll aufgedrehtem Spannungspoti) zu schwingen.
Und zwar habe ich dann am Ausgang der Schaltung "Nadelimpulse mit einer
langsam fallen Flanke", praktisch umgekehrte Sägezahnimpulse. Am Ausgang
des oberen OpAmps messe ich eine Dreieckspannung. Hilft es in diesem
Fall was, den TIP32 durch einen NPN zu ersetzen?

Gruß
Thomas Stegemann

--------------42FB8CD09EF5332C58333693
Content-Type: text/html; charset=us-ascii
Content-Transfer-Encoding: 7bit

<!doctype html public "-//w3c//dtd html 4.0 transitional//en">
<html>
Hallo!
<p>Ich habe folgendes Labornetzteil heute aufgebaut:
<br><a
href="
http://ourworld.compuserve.com/homepages/Bill_Bowden/ps6.gif">
http://ourworld.compuserve.com/homepages/Bill_Bowden/ps6.gif</a><a
href="
http://ourworld.compuserve.com/homepages/Bill_Bowden/ps6.gif"></a>
<p>Nur das ich den LM1458 durch einen LM358 ersetzt habe, sollte doch kein
Problem sein, oder? Den 2N3053 habe ich (weil ich ihn leider &uuml;bersehen
habe :-() durch einen BC140 ersetzt. Aber die Schaltung gibt entweder 0V
aus oder sie beginnt (bei voll aufgedrehtem Spannungspoti) zu schwingen.
Und zwar habe ich dann am Ausgang der Schaltung "Nadelimpulse mit einer
langsam fallen Flanke", praktisch umgekehrte S&auml;gezahnimpulse. Am Ausgang
des oberen OpAmps messe ich eine Dreieckspannung. Hilft es in diesem Fall
was, den TIP32 durch einen NPN zu ersetzen?
<p>Gru&szlig;
<br>Thomas Stegemann</html>

--------------42FB8CD09EF5332C58333693--


Re: Labornetzteil
Quoted text here. Click to load it

Kann schon ein Problme sein, vor allem wenn man Schwingprobleme hat...
Der LM358 hate eine ruhestromlose Ausgangsstufe.
Damit ist die Regelschleife weniger linear.

Quoted text here. Click to load it

Das ist in Ordnung, den 2N3055 hast du ja auch ersetzt...

Quoted text here. Click to load it

Tja ja, hatte ich vor gewarnt.

Quoted text here. Click to load it
Es verringert die Verstaerkung der Schleife, hilft also gegen Schwingneigung
(Emitter an Basis des 2N3055, Polung OpAMp umdrehen, 1N914 auch),
aber beseitigt natuerlich nicht dessen Ursache. Da *im Prinzip*  die
Originalschaltung auch gehen sollte, und du so massive Schwingprobleme hast,
wuerde ich mal dessen Ursache suchen. Fehlersuche bildet ja.
Trenn erst mal den Stromregleropampausgang ab.
Schwingt schon der Spannungsregler alleine ? (und umgekehrt mit Lastwiderstand)
Bei jeder Einstellung ?
(wenn er nur schwingt, wenn das Poti knapp am oberen Anschlag ist,
schalte einen 4k7-Widerstand zwischen Poti und Eingang (Rueckkoppel-C)).
--
Manfred Winterhoff, reply-to invalid, use mawin at despammed.com
homepage: http://www.geocities.com/mwinterhoff /
We've slightly trimmed the long signature. Click to see the full one.
Re: Labornetzteil
Quoted text here. Click to load it

Wäre dann der NE5532 ein besserer Ersatz? Den LM1458 kann ich nur als
SMD-Version bei
Reichelt finden.

Gruß
Thomas Stegemann



Re: Labornetzteil
Quoted text here. Click to load it

Jein. Der NE5532 hat Dioden am Eingang
   K  A
 --+--+--|+\
   D  D  |  >--
 --+--+--|-/
   A  K
das stoert (Spannungspoti oberer Anschlag obwohl
Ausgangsspannung noch nicht gefallen ist -> Diode
leitet nach Masse). Man kann natuerlich was dagegen tun
(die 4k7 vom vorigen Posting helfen hier auch).

Quoted text here. Click to load it

LM1458 ist nur der Nachbau, RC1458 ist das Original, hat Reichelt
auch nicht, aber MC1458 (17 Cent, was will man mehr).
RC4558/NE4558/NJM4558/BA4558 geht wohl auch.
Es gibt noch den MC33078.
Oder uA741, braucht man halt 2 Stueck.
Was hast du denn in der Bastelkiste ?

Versuch es erst mal mit dem LM358. Da er ein anderer OpAmp ist
als im Originalschaltplan, muss er halt anders kompensiert werden,
also die 10nF/100nF Kondensatoren angepasst werden.

Dann geht es irgendwann auch.

Wenn man dann versucht, die Schaltung optimal auszulegen (also mit
geschalteter Last am Oszilloskop die optimale Auslegung der
Regelschleife zu ermitteln), wird man eventuell feststellen, das der
LM358 nicht so schnell regelt, wie der 1458. Na ja, der 1458 ist auch
nicht der Hit, also wird man nicht wirklich traurig sein.
--
Manfred Winterhoff, reply-to invalid, use mawin at despammed.com
homepage: http://www.geocities.com/mwinterhoff /
We've slightly trimmed the long signature. Click to see the full one.
Re: Labornetzteil
Quoted text here. Click to load it

Also zwei uA741 hätte ich hier noch rumfliegen.
Wenn es gar nicht anders geht werde ich es damit probieren. Aber erstmal mit
LM358, muss
doch möglich sein. :-)
Ein anderes Problem ist mir noch aufgefallen:
Beim drehen des Poti bricht die negative Spannung an der Zenerdiode zusammen.
Hat LM358 irgendwie einen zu kleinen Eingangswiderstand?

Gruß
Thomas



Re: Labornetzteil
Quoted text here. Click to load it

Geht.

?!? Da liegen 4k7 dazwischen.
Irgendeinen Kurzschluss ?

GND des LM324 an Massse und nicht an V- (-12V) ?
--
Manfred Winterhoff, reply-to invalid, use mawin at despammed.com
homepage: http://www.geocities.com/mwinterhoff /
We've slightly trimmed the long signature. Click to see the full one.
Re: Re: Labornetzteil

Quoted text here. Click to load it
Hast du denn ein lineares Poti eingebaut?
Ich meine allerdings, dass du längerfristig mit einem 10-Gang-Poti
glücklicher wirst. Das würde ich allerdings auch erst erwerben, wenn
deine Entscheidung für eine Schaltung endgültig ist und der notwendige
Wert feststeht.

Quoted text here. Click to load it
schalten?

In  http://mitglied.lycos.de/hobbyelec/spannung-messen/NT40315.GIF
hast du einen guten Vorschlag für die Leistungstransistoren.

Erich


Re: Labornetzteil
Quoted text here. Click to load it

Ja, klar!

Gruß
Thomas Stegeman



Re: Labornetzteil
Quoted text here. Click to load it

Ja, klar!

Gruß
Thomas Stegemann



Re: Re: Labornetzteil
Quoted text here. Click to load it

Auf diese Art und Weise hab ich mir vor jetzt 20 Jahren ein 10A-
Festspannungsnetzteil mit insgesamt 4 über Emitter-
Ausgleichswiderstände parallel geschalteten 2N3055 gebaut. Das wird
dann natürlich schon ein recht großer Kühlkörper...

Grüße

Stefan

Re: Labornetzteil

Quoted text here. Click to load it

Schoen. Was war's denn nun ? Leitungsfuehrung ?

Quoted text here. Click to load it

Ja, bei dieser Schaltung Absicht. Ist auch recht praktisch, denn man
will eher prozentuale Einstellgenauigkeit.

Quoted text here. Click to load it

Da sind 0.1uF drin, und das gegen ca. 6kOhm, also kein Wunder.
Kleinerer Kondensator, schnellere Reglung. Zu kleiner Kondensator,
schwingt (kennst du).

Quoted text here. Click to load it

30V/3A haette er aushalten muessen. Bei 40V aber nur noch 1.5A.
Stellt sich also die Frage, wie hach die Spannung am Siebelko ist/war.

Quoted text here. Click to load it
einzigen

Emitter jeweils ueber 0.1 Ohm zum Verknotungspunkt leiten,
Nennt man Stromverteilungswiderstaende.
--
Manfred Winterhoff, reply-to invalid, use mawin at despammed.com
homepage: http://www.geocities.com/mwinterhoff /
We've slightly trimmed the long signature. Click to see the full one.
Re: Labornetzteil
Quoted text here. Click to load it

Wohl eine Kombination aus allem. Der 4,7k Widerstand hat der Schaltung das
Schwingen
abgewöhnt und dann lief sie plötzlich. Dann hab ich noch ein paar Veränderungen
vorgenommen um die Schaltung stabiler zu machen (z.B. größerer Steuertransistor
as der
BC140).

Quoted text here. Click to load it

D.h. ein Getriebe wäre nicht übel, oder? Hab zum Glück noch eins da.

Quoted text here. Click to load it

Ich probiere mal was kleineres weil mir die Strombegrenzung so etwas zu langsam
ist.

Quoted text here. Click to load it

Wie ich sagte verwende ich einen Trafo mit 2 15 Volt Wicklungen, d.h. am Siebelko
standen knapp 40V an. Hätte aber nicht gedacht das der BD249 sich so schnell aus
der
Ruhe bringen läßt. Hätte ich mal dran denken müssen an die 90W (selber Schuld).

Quoted text here. Click to load it

Gut, reichen zwei 2N3055?

Gruß
Thomas



Re: Labornetzteil
Quoted text here. Click to load it

Woher weisst du, das sie stabiler geworden ist ? Pruefst du das Ausregelverhalten
mit Oszilloskop an einer geschalteten Last ?
Quoted text here. Click to load it

Na ja, eigentlich gerade bei dieser Einstellform nicht so noetig .
Bei 1V kann man wegen der gedehnten Skala einfach auf 1.1V genau einstellen.
Bei 24V will man gar nicht auf 24.1V genau einstellen, da reichen 24.5.
insofern ist die Skala angemessen.

Und es stellt sich die Frage, ob denn das Poti so gut ist, das es auf das
Getriebe reagiert, die meisten Potis sind da eher unpraesize. Leitplastik
waere gut, vertraegt aber meist nicht so viel Strom.
Quoted text here. Click to load it
Nein, die 90W sind nicht das Mass aller Dinge. Schau ins Datenblatt. Das
SOA-Diagramm ist entscheidend.

Quoted text here. Click to load it
Kannst du dir selbst beantworten mit einem Blick ins Datenblatt:
SOA-Area: Bei 40V mehr als 1.5ADC, also OK. Verlustleistung 40V*1.5A60%W.

Geht, aber:

Power Derating: Erlaubte Gehaeuesetemperatur bei 60W: mehr als 100 GradC.
Kuehlkoerper fuer 2 Transistoren mit 100 GradC bei 40GradC Umgebungstemp:
(100-40) / (2*60W) = 0.5K/W. Schon ein groesseres Modell.
Nun weisst du, warum im Original die Trafospannung umschaltbar ist.
Das kannst du mit deinem 2*15V Trafo aber auch machen.
--
Manfred Winterhoff, reply-to invalid, use mawin at despammed.com
homepage: http://www.geocities.com/mwinterhoff /
We've slightly trimmed the long signature. Click to see the full one.
Re: Labornetzteil
Quoted text here. Click to load it
Ausregelverhalten
Quoted text here. Click to load it

Nein, hab leider keine elektronische Last :-(
Ich meine stabiler im Sinne der Bauteildimensionen (BC140 wurde teuflisch heiß).

Habe leider keine 2N3055 mehr da gehabt, habe deshalb provisorisch erstmal alte
Zeilentransistoren (2*BU208) parallel geschaltet. Funktioniert erstmal auch, ist
aber ne
prima Heizung! Habe für die beiden schon einen wirklich großen Kühlkörper
genommen (ca.
20*10cm, nicht komplett verript). Ab einer bestimmten Temperatur machen die
Transistoren
"klirrende" Geräusche, ich glaube das ist kurz vor dem Hitzetod. Nach einer
Minute
Vollast (3 Ampere) ist dieser Zustand erreicht. Mit einem Lüfter kann ich ihn
bis ca. 5
Minuten herauszögern.
Aber das kann es doch nicht sein, oder? Ist das Verhalten der 2N3055 so stark
anders?
Werde mir nächste Woche mal ein paar besorgen. Wenn die Schaltung
temperaturstabil ist,
werde ich mal probieren die Regelgeschwindigkeit durch kleinere C's zu
verringern.

Gruß
Thomas



Re: Labornetzteil
Quoted text here. Click to load it

100Hz NE555 an 12V oder 9V Blockbatterie + BUZ10 + Belastungswiderstand
Siehe de.sci.electronics FAQ: http://dse-faq.elektronik-kompendium.de /

Quoted text here. Click to load it
Ja, einen Kuehlstern braucht er in der Schaltung schon,
3 Watt entstehen in der Schaltung als Verlustleistung,
aber deswegen wurde ja auch ein kuehlbarer Transi verwendet.

Quoted text here. Click to load it
anders?

Nein, die muessen genau so viel Waerme los werden.
Die Metallgehaeuse duerfen aber heissser werden als Plastikgehause und
leiten die Waerme besser ab, sind dafuer laestiger zu montieren.

Allerdings ha ich das Daetnnblatt des BU208 nicht, kann sein das er bessere
oder schlechtere Stromverstaerkung hat und schlechten Waermewiderstand.
--
Manfred Winterhoff, reply-to invalid, use mawin at despammed.com
homepage: http://www.geocities.com/mwinterhoff /
We've slightly trimmed the long signature. Click to see the full one.
Re: Labornetzteil

Quoted text here. Click to load it
anders?

Quoted text here. Click to load it

Der BU 208 ist gebaut für TV-Horizontal-Ablenkung. Sein
stromverstärkungfaktor beträgt, üblich für diesen anwendungszweck, bei
B=>2,45. P12%,5W. Beim  2N3055 liegt B zwischen 20-70 bei P11%5W.
Der BU 208 ist ungeeignet. Es sollte schon ein 3055 oder ähnlich
eingesetzt werden. Dann dürfte auch der BC 140 grad ausreichen.
--
mfg horst-dieter


Re: Labornetzteil
Quoted text here. Click to load it

Klar, hab ihn auch aus einem alten Chassis.

Quoted text here. Click to load it

Gut, das wollte ich nur hören *g*
Obwohl es trotzdem funktioniert...nur etwas heiß...
Werde mir dann ein paar 3055 besorgen und damit hoffentlich glücklich werden.
Den BC140 verwende ich schon nicht mehr. Habe noch einen BD267 gefunden,
funktioniert
prima, da ich ihn gleich mit auf den kleinen Kühlkörper (Gleichrichter, BD267,
TIP32)
montieren konnte.

Gruß
Thomas





Re: Labornetzteil
Quoted text here. Click to load it

Danke, aber den Tip hat MaWin mir auch schon gegeben, habe jetzt 4,7k vor OP.



Re: Labornetzteil
Hi!

Sind denn noch andere Schutzmaßnahmen (wie zum Beispiel Damper-Diode am Ausgang)
erforderlich? Oder ist das Netzteil mit seiner Strombegrenzung von außen her
unverwüstlich?

Gruß
Thomas


Re: Labornetzteil
Quoted text here. Click to load it
Ausgang)
Quoted text here. Click to load it
Kein Netzteil ist unverwuestlich, wie es schnell bewiesen wird,
wenn man 230V~ in den Ausgang stopft.
Eine 1N5401 Diode 'verkehrtherum' parallel am Ausgang stoert bei
normalen Betrieb nicht und verhindert Verpolung von aussen.
Eine 1N5402 Diode vom Ausgang zum Ladeelkeo verhindert Probleme
mit Ueberspannungsspitzen. Mehr ist nicht sinnvoll/noetig.
--
Manfred Winterhoff, reply-to invalid, use mawin at despammed.com
homepage: http://www.geocities.com/mwinterhoff /
We've slightly trimmed the long signature. Click to see the full one.

Site Timeline