F: Op-Amp und Fototransistor

Do you have a question? Post it now! No Registration Necessary

Translate This Thread From German to

Threaded View
Hallo zusammen!

Da ich im Moment leider nicht mehr weiterweiss:
Ich habe folgende Schaltung:
http://www.kullenhof.de/~gantweiler/pics/Sensor.jpg(50kB)

Diese habe ich grösstenteils vorgegeben bekommen und vorher auf
Lochraster aufgebaut. Dort hat sie ohne Probleme funktioniert.

Die Aufgabe besteht darin einstellbar eine Licht-Helligkeit als
TTL-Signal auf den 9-pol Stecker zu geben.
Es handelt sich um die Farbe Weiss und daher kam bevorzugt der
Fototransistor BPW96 in Betracht.
Der Op-Amp ist ein TL062P.
Die Schaltung ist symmetrisch aufgebaut, da es sich um zwei Sensoren
handelt.

Problem: da die Probeschaltung ohne Probleme geklappt hat, ist die
Platine geätzt worden und somit sind meine Änderungsmöglichkeiten
limitiert.
Die Fehlfunktion äussert sich darin, dass die Schaltung nicht mehr auf
Licht reagiert. Zudem - wenn der Trimmer zur Empfindlichkeit
eingestellt wird - fällt die Spannung ab einem bestimmten Punkt an dem
Transistor von 2,8V auf 0.63V und kommt nicht mehr hoch (Reset der
Schaltung notwendig).

Inzwischen nochmals auf Lochraster nachgebaut, habe ich leider
denselben Fehler.
Der nachgeschaltete 4050er ist einfach nur ein Treiber, um einen
stabilen TTL-Pegel zu erzeugen.
Beim Layout ist auf kurze Wege zu den Eingängen des Op-Amps geachtet
worden (Minimierung der Fehleranfälligkeit).

Habt ihr noch eine Idee dazu?

Vielen herzlichen Dank!

Guido

Re: F: Op-Amp und Fototransistor
Hallo Guido,

Muss beim BPW96 nicht mit hoeherem Strom gerechnet werden? Die 10K Widerstaende
und 100K Trimmer sehen etwas hoch aus. Nur mal eine Idee, Experte bin ich bei
Photo Transistoren nicht.

BTW, USBid hat BPW96 auf der Liste. Ich wuerde mal nachsehen, ob und wie lange
er noch produziert wird. Ich kann mich in diesem  Fall irren, aber USBid handelt
meist mit "Obsoleted Parts". Im Zweifel mal bei Vishay nachfragen.

Gruesse, Joerg

http://www.analogconsultants.com

Re: F: Op-Amp und Fototransistor
Hallo Joerg!

Quoted text here. Click to load it
und 100K Trimmer sehen etwas hoch aus. Nur mal eine Idee, Experte bin ich bei
Photo Transistoren nicht.

Nein, die passen soweit.


Herzlichen Dank ;)

Guido

Re: F: Op-Amp und Fototransistor
Hallo nochmals ;)

Noch vergessen: da der BPW96A schwer zu bekommen war, bin ich auf den
BPW 16 N gekommen... damit habe ich die Schaltung(en) auch erfolgreich
getestet.

Datenblatt BPW16N - http://www.vishay.com/docs/81515/81515.pdf
Datenblatt BPW96A - http://www.vishay.com/docs/81532/81532.pdf

cu

Guido

Re: F: Op-Amp und Fototransistor
Hallo ;)

Und da es so schön war ;)

Quoted text here. Click to load it

Datenblätter TL062P:
http://www.kullenhof.de/~gantweiler/pics/TL061_TL062_TL064_TEX.pdf
http://www.kullenhof.de/~gantweiler/pics/TL062_STM.pdf

cu

Guido

Re: Op-Amp und Fototransistor
Quoted text here. Click to load it


Hallo Guido,
mich wundert schon mal, daß jemand den TL062 mit 5V betreibt.
Für diese Spannung wird im Datenblatt gar nichts garantiert.
Es gibt viele Opamps für kleine Versorgungsspannungen.
Du hättest natürlich auch gleich einen Komoarator verwenden
könnnen, z.B. LM393. Der ist Pin-kompatibel, benötigt aber
einen Widerstand nach V+ am Ausgang.
http://cache.national.com/ds/LM/LM193.pdf
Aber teste erst mal die Änderung die ich weiter unten vorgeschlagen habe.

Quoted text here. Click to load it


Deine Mitkopplung mit dem 47kOhm ist ziemlich heftig im Vergleich
zu den 100kOhm deines Potis.
Erhöhe diesen Widerstand (R3, R4, Opamp-Ausgang nach in+) von 47kOhm
auf 470 kOhm.

Welchen High-(Low)-Pegel schafft eigentlich der TL062 in deiner
5V-Anwendung?

Gruß
Helmut



Re: Op-Amp und Fototransistor
Hallo Helmut!

Quoted text here. Click to load it

Tja... die Schaltung war eben soweit vorgegeben und lief bereits in
den Parametern.


Quoted text here. Click to load it

Bei denen muss ich mal schauen...


Quoted text here. Click to load it

Ja, das wäre eine Idee ;)


Quoted text here. Click to load it

Habe ich gemacht: leider keine Änderung bzgl. Schaltvorgang.


Quoted text here. Click to load it

4,5V und 0,63 - aber wie gesagt: ich bekomme leider keinen
helligkeitsbasierten Schaltvorgang mehr hin.

*frustriert*

Guido

Re: Op-Amp und Fototransistor
Quoted text here. Click to load it

Hallo Guido,
vielleicht ist es einfach zu hell.
Reduziere den Poti-Vorwiderstand(R7) auf 1kOhm.
Zusammen mit der Änderung des Mitkopplungswiderstands auf 470 kOhm
sollte der Opamp zwischen high und low schalten falls es nicht
immer noch zu hell ist. Schaltpunkt is ungefähr bei 2.5V am
Fototransistor.

Noch ein Tipp zum Messen.
Welche Spannungen ergeben ich an der Schnittstelle Fototransistor->
R7 wenn du das Poti an beiden Anschlägen hast?

Ist dein Fototransistor richtig gepolt eingelötet?

Gruß
Helmut




Re: F: Op-Amp und Fototransistor
Hallo Guido,

Wie Helmut sagte, der Versorgungsbereich des Opamps muss laut Datenblatt
zulaessig sein. Ausserdem muss der Common Mode Range eingehalten werden. Es gibt
Amps, die nicht richtig arbeiten, wenn Ein oder Ausgaenge zu nahe an eine der
Versorgungsspannungen geraten. Bei unipolarem Betrieb ist dann eine der
"Spannungen" Masse.

Manchmal sind es mehrere Volt, die man wegbleiben muss von den Spannungen,
zumindest von der positiven. Das kann oft selbst einen Opamp fuer diese
Anwendung unbrauchbar machen, der fuer 5V zulaessig waere. Fies ist hier, dass
es manchmal trotzdem funktioniert, aber wenn dann die naechste Ladung Chips aus
einem anderen Produktionszyklus kommt, geht nichts mehr.

Dann bliebe nur, nach einem Pin kompatiblen echten "Rail-to-Rail" Opamp zu
suchen. Texas, National usw.

Gruesse, Joerg

http://www.analogconsultants.com

Re: F: Op-Amp und Fototransistor
Hallo zusammen!

So: mein Problem ist durch die äusserst konstruktive Hilfe von Dir
Joerg und vor allem Dir Helmut gelöst worden ;)

Vielen Dank auch an die anderen - es haben sich sicher noch einige
Gedanken gemacht - und wenn nicht: dann für's Lesen :D

Bis bald!

Guido

PS: ich grüsse einfach mal MaWin ;)

Site Timeline