AVRISP Update Problem

Do you have a question? Post it now! No Registration Necessary

Translate This Thread From German to

Threaded View
Ich habe ein Problem mit dem Firmware Upgrade des AVRISP. Wenn ich das
AVRISP starte erhalte ich die Meldung das AVRStudio eine neue Firmware
downloaden möchte. Version 0x01.0x0E ist im AVRISP und die neue Version
ist 0x01.0x0F. Wenn ich das mit OK bestätige wird auch eine neue
Firmware runtergeladen. Als letztes wird wohl ein Verify gemacht und da
erhalte ich eine Fehlermeldung dass auf Adresse 0x0000, 0x0000 gelesen
wird anstatt 0xC012. Woran könnte das liegen? 5V kommen vom Target und
ausser dem 2313 ist nichts weiter an den Programmierleitungen vom AVRISP
zum Target angeschlossen. Das Target läßt sich einwandfrei
programmieren.

Wolf


Re: AVRISP Update Problem
Quoted text here. Click to load it

Hallo,

evt. hängt es mit dem Target zusammen. Nach diversen Problemen mit dem
Firmware-Update des AVRISP bei angeschlossenem Target programmiere ich die
Dinger jetzt nur noch so, daß ich über zwei aufgebogene Büroklammern +5V und
GND in den Pfostenstecker des AVRISP-Kabels einspeise und somit ohne
Targeteinflüsse arbeite. Seit dem klappt es.

Gruss Ronald
---
EMail: ronald<Punkt> snipped-for-privacy@gmx.de




Re: AVRISP Update Problem
Quoted text here. Click to load it

Besten Dank, das hat geholfen. Ich habe mir noch eine extra Stiftleiste
auf ein Stückchen Lochrasterplatine mit 2 Anschlüßen für die
Stromversorgung gebaut. Wer weiß wie oft man das noch braucht.

Grüße Wolf


Site Timeline