USB-Problem

Do you have a question? Post it now! No Registration Necessary

Translate This Thread From German to

Threaded View
Hallole,

ohne in gerätespezifsche Dinge einsteigen zu wollen:
Ich muß an einem älteren MB (HOT-553 von Shuttle, USB-taugliche
Intel-Chipsatz-Version, Win98SE) einen USB-Card-Reader (Tevion 6in1)
betreiben. USB ist im BIOS aktiviert, Treiber installiert, USBREADY
von Intel meldet dreimal grün (BS, Hardware, Treiber). In der
Hardwareliste ist die USB-.Sektion mit USB-Controller und -Stammhub
ordentlich eingetragen. Müßte also alles klappen - tut es aber nicht.
Kein einziges USB-Gerät wird beim Einstöpseln erkannt - in der
USB-Sektion erscheint jedesmal nur der Eintrag "Unbekanntes Gerät" -
egal welches USB-Gerät es ist. Die USB-Geräte selbst sind aber
nachweislich okay.
In meiner Not habe ich mir das USB-Anschlußkabel angeschaut (auf dem
MB ist eine 2x4-Steckerleiste für USB-Port 1 und 2). Das habe ich vor
2 Jahren dazu gekauft - weiß leider nicht mehr bei wem. Die
Reihenfolge der farbcodierten Kabel am Stecker stimmt jedenfalls mit
der angeblichen Pinbelegung auf dem MB überein. Optisch also alles
o.k. Und zumindest die Versorgungsspannungsbelegung muß o.k. sein, den
immerhin wird ja der Anschluß eines Geräts also solches erkannt und
bei allen USB-Geräten, die eine Betriebsanzeige besitzen, leuchtet die
entsprechende LED. Aber: Beim Aufstecken der Steckbuchse auf die
Steckerleiste auf dem MB _ohne_ (!) daß ein USB-Gerät angeschlossen
war reagiert das System darauf!. Einmal - allerdings nicht
reproduzierbar - erschien kurz die Anzeige "unbekanntes Gerät". Bei
den folgenden Test wurde die aufgeklappte USB-Sektion (also mit
sichtbaren Einträgen) eingeklappt (Einträge nicht mehr sichtbar).
Passiert bei jedem Aufstecken der Steckbuchse, manchmal auch bei deren
Abziehen. Wie gesagt: Ein Gerät ist an die USB-Buchse _nicht_
angeschlossen. Denn reagiert das System auf das Aufstecken des Kabels
mit der USB-Anschlußbuchse.
Wier kann das sein? Das USB-Adapterkabel ist doch nur eine
Verlängerung der vier Steckkontakte auf dem MB mit angelaschten
USB-Stecker. Oder steckt da irgendeine "Intelligenz" drin, so daß
evtl. eine "defekte" oder sonstwie "unpassende" USB-Anschlußbuchse die
Ursache sein kann, daß das System trotz (angeblich) funktionierender
Hard- und Software kein einziges USB-Gerät erkennt?

Beste Grüße

Dr. Michael König
--
    RA Dr. M. Michael König * Anwaltskanzlei Dr. König & Coll.
          D-65843 Sulzbach/Ts. * Antoniter-Weg 11
We've slightly trimmed the long signature. Click to see the full one.
Re: USB-Problem
Quoted text here. Click to load it
 
Hallo Michael,

Details zu den Anschlüssen siehe z.B. hier:
http://www.usbman.com/Guides/BelkinMotherboard_cable_assembly.htm

Die Anschlüsse auf den Motherboards sind nicht genormt und die
USB-Erweiterungen mit den Anschlüssen ebensowenig. Man muss daher die
Belegung kontrollieren. Die Kabel haben keine Eigenintelligenz.

HTH


Bernd Mayer



Quoted text here. Click to load it

--
MR. MCBRIDE: "Yes, Your Honor. ... I want to walk the Court through
enough of our complaint to help the Court understand that IBM clearly
We've slightly trimmed the long signature. Click to see the full one.
Re: USB-Problem

Moin Bernd,

Quoted text here. Click to load it

öhm, so ein Cardreader ist kein USB-Verlängerungskabel, da steckt
schon ein Chip drauf.

Rainer

--
Microsoft hat *nichts* auf der Homepage; nicht wirklich. Das ist
alles nur Schein. Die Wahrheit ist HIER. Hier ist das USENET.
We've slightly trimmed the long signature. Click to see the full one.
Re: USB-Problem
Rainer Knaepper schrieb:

Quoted text here. Click to load it


Das hat er auch nicht behauptet! Es geht um die Verbindung MoBo zu den
USB-Anschlüssen. Und die sind nicht genormt.

Gruss Wolfgang
--
No reply to "From"! - Keine Antworten an das "From"
Keine privaten Mails! Ich lese die NGs, in denen ich schreibe.
We've slightly trimmed the long signature. Click to see the full one.
Re: USB-Problem
Quoted text here. Click to load it
 
Hallo Rainer,

so wie ich das verstehe ist das ein externer Cardreader. Mein posting
bezieht sich auf das Kabel vom Motherboard zum Slotblech, wie es auch im
link abgebildet ist.

Grüsse


Bernd Mayer
--
MR. MCBRIDE: "Yes, Your Honor. ... I want to walk the Court through
enough of our complaint to help the Court understand that IBM clearly
We've slightly trimmed the long signature. Click to see the full one.
Re: USB-Problem

Moin moin,

snipped-for-privacy@knuut.de (Bernd Mayer)  meinte am 19.01.04

Quoted text here. Click to load it

ok, habe ich dann flahsc verstanden

Rainer

--
Halber vier, Kaulquapp,
und die Männer haben noch keinen Strick getan.

Re: USB-Problem
RA Dr.M.Michael König schrieb:
Quoted text here. Click to load it

Schon den USB-Patch probiert?

http://support.microsoft.com/default.aspx?scid=kb ;de;240075

viele grüße
ralph


Re: USB-Problem
Am Mon, 19 Jan 2004 12:56:42 +0100, meinte "Ralph 'rkhb' Bauer"

Quoted text here. Click to load it

Betrifft mich zwar nicht, da Intel-Chipsatz i430HX und "lahmen"
Prozessor (K6, 233 MHz), aber dennoch ausprobiert: Keine Änderung.

Beste Grüße

Dr. Michael König
--
    RA Dr. M. Michael König * Anwaltskanzlei Dr. König & Coll.
          D-65843 Sulzbach/Ts. * Antoniter-Weg 11
We've slightly trimmed the long signature. Click to see the full one.
Re: USB-Problem

Quoted text here. Click to load it


http://66.102.11.104/search?q=cache:YIocig9Ljd0J:de.shuttle.com/553_faq.htm+HOT-553+usb+Shuttle+problem&hl=en&ie=UTF-8
  ---
| Der i430HX Chipsatz besteht aus zwei Chips. Das PIIX3-Chip mit der
| Bezeichnung 82371SB enthält den USB-Anschluß. Bei der A1-stepping
| Version (SU052) ist der USB-Port noch nicht funktionfähig. Erst das
| B0-stepping (SU093) unterstützt die USB-Funktion vollständig.
  ---
Schon überprüft?
--
Das Recht auf Anonymität: http://www.realname-diskussion.info/anonheft.htm
Pseudonym? Aber sicher! http://www.realname-diskussion.info/pseudo.htm
We've slightly trimmed the long signature. Click to see the full one.
Re: USB-Problem
Am Sun, 25 Jan 2004 15:55:02 +0100, meinte
me snipped-for-privacy@nospam.arcornews.de:

Quoted text here. Click to load it

Selbstverständlich., Steht auch schon in meiner Anfrage.
Aber:
Nach einiger weiterer Recherche bin ich bei Intel im Dokument
http://www.intel.com/design/support/faq/embed_chipset/430hx.htm
auf den Hinweis
"Does the PIIX3 support USB?
....
There may also be compatibility issues. The PIIX3 only supports USB
Specification 1.0. The majority of USB devices today are USB 1.1
compatible, with some being USB 2.0 enabled. Because the specification
change from USB 1.0 to USB 1.1 involved both hardware and software
upgrades, there is no way for the PIIX3 to support USB 1.1. Contact
the USB device manufacturer to determine whether or not the device is
USB 1.0 compliant. Additional information is available from the Intel
USB web site. "
gestoßen. Wenn dies zutrifft, dann würde dies natürlich erklären,
warum Mainboard und USB-Gerät nicht kommunizieren können - die
USB-Geräte sind nur USB 1.1-kompatibel, nicht aber USB 1.0. Und wenn
die MB-Hardware nur USB 1.0 kann, ist nachvollziehbar, daß das
Anstecken eines Geräts zwar erkannt wird, der Typ mangels
funktionierender Kommunikation aber nicht.

Beste Grüße

Dr Michael König

--
    RA Dr. M. Michael König * Anwaltskanzlei Dr. König & Coll.
          D-65843 Sulzbach/Ts. * Antoniter-Weg 11
We've slightly trimmed the long signature. Click to see the full one.
Re: USB-Problem

Quoted text here. Click to load it

Ob in dem Kabel irgendwelche "Intelligenz" drin ist, läßt sich mit einiger
Sicherheit mittels eines Durchgangsprüfers feststellen (ist aber nicht
wahrscheinlich).

Ich würde einfach von einer Fehlbelegung des Kabels ausgehen. Daß das Board
darauf regaiert, könnte bedeuten, daß durch die Fehlbelegung eine
Signalader des USB-Ports auf +5V oder GND gezogen wird - was als
"Aktivität" gewertet wird. Damit bekommt man fix einen feinen Kurzschluß
hin - woraufhin entweder das Board stirbt oder das Kabel fein warm wird
(+5V im PC kann einige A liefern).

Mit etwas Glück treibt man irgendwo ein Pinout des USB-Anschlusses am Board
auf und kann das Kabel entsprechend ändern. Sonst muß man probieren - bei 4
Leitungen und genormten USB-Steckern ist das ja nicht so viel Aufwand. Vcc
und GND sollten sich am Mainboard-Anschluß leicht herausfinden lassen -
bleiben 2 Möglichkeiten. Viele Boardanschlüsse haben 5 Pins, dann ist einer
NC oder GND.

Sebastian

Re: USB-Problem
Quoted text here. Click to load it
Board
4
einer

Bei allen Boards, die ich bisher sah, waren die Anschlüsse ähnlich:

+5V
-Data
+Data
GND
ev. GND

Mal von rechts nach links, mal von links nach rechts, wenn 2 Reihen sind,
liegen oft beide parallel, manchmal aber auch eine Reihe so, eine so herum,
antiparallel sozusagen.

--
Wolfgang Horejsi



Re: USB-Problem
Quoted text here. Click to load it

Hallo Sebastian,

Standard-Umgang mit Suchmaschinen kann auch schon ausreichen:

http://www.google.com/search?q=HOT-553+von+Shuttle
führt zu http://de.shuttle.com/553.htm
und hier gibt es das Manual auf deutsch als gezipptes PDF:
ftp://ftp.shuttle.com/Manuals/ge/553/553.ZIP
darin die PIN-Belegung.

HTH


Bernd Mayer
--
MR. MCBRIDE: "Yes, Your Honor. ... I want to walk the Court through
enough of our complaint to help the Court understand that IBM clearly
We've slightly trimmed the long signature. Click to see the full one.
Re: USB-Problem
Am Mon, 19 Jan 2004 16:14:34 +0100, meinte Bernd Mayer

Quoted text here. Click to load it

Danke, aber _das_ kenne ich natürlich schon längst. Und habe auch
schon eine längere und ebenso unerquickliche wie ergebnislose
Korrespondenz mit dem Shuttle-Support hinter mir. Deswegen will ich
auch nicht auf Hardware-Spezifika hinaus, denn mehr als der
Shuttle-Support über die eigenen Boards (nicht) weiß wird hier auch
niemand wissen.
Die - angebliche - Pin-Belegung auf dem MB paßt zu der - angeblichen -
Farcodierung der USB-Leitungen des Adapters.
Aus dem dennoch gleich bei zwei MBs zutragetretenden Problemen
("Kommunikationsproblemen") resultiert ja gerade meine Verzweifelung.

Beste Grüße

Dr. Michael König
--
    RA Dr. M. Michael König * Anwaltskanzlei Dr. König & Coll.
          D-65843 Sulzbach/Ts. * Antoniter-Weg 11
We've slightly trimmed the long signature. Click to see the full one.
Re: USB-Problem

Quoted text here. Click to load it

Das ist doch auch vollkommen richtig so, was hast du denn
erwartet?
Win98SE ist nun mal schon etwas älter, da kennt es einiges,
was in den letzten Jahren erfunden wurde, nicht...
Normal muß man da die zu den Geräten mitgelieferten Treiber
installieren, und dann funktioniert das. Es gibt nur sehr
wenige USB-Geräte, für die Win98SE selbst Treiber hat, und
auch bei denen müssen die erst von der Win98-CD nachinstalliert
werden, das mit dem "Anstecken und geht" funktioniert erst
nachdem die Treiber einmal installiert sind.

Quoted text here. Click to load it

Wenn die Spannung richtig anliegt dürfte da nicht viel falsch
sein.

Quoted text here. Click to load it

Man sollte grundsätzlich nicht an dem Board rumstöpseln,
während es in betrieb ist...

Frank


Re: USB-Problem
Am Mon, 19 Jan 2004 16:49:13 +0100, meinte Frank Müller

Quoted text here. Click to load it

Etwas anderes. Nämlich daß die bereits installierten Treiber verwendet
bzw. vorhandene Treiber erkannt werden.

Quoted text here. Click to load it

Entschuldigung: Ich habe zwar kein Techniker-Diplom, bin aber seit den
Anfängen der HC und PC "dabei" und daher durchaus mit dem üblichen
procedere vertraut - Sie brauchen mir daher nicht zu unterstellen, ich
würde das übliche Vorgehen nicht kennen. Wenn ich also hier frage,
dann nicht, weil ich Probleme mit der Installation eines Treibers
hätte.
Also:
Bei besagten CardReader ist die für Win98(SE) übliche, empfohlene und
bei anderen WIN9-Systemen funktionierende Vorgehensweise, zunächst die
Treiber zu installieren, dann zu booten und dann das Gerät
einuzstöpseln. genau dies funktioniert bei mir nicht: Trotz
installiertem Treiber wird das Gerät nicht als solches sondern nur als
"unbekanntes Gerät" erkannt. Umgekehrt wird´s natürlich auch nichts.
Anderes Beispiel: USB-Maus: Vorhander Treiber wird installiert, neu
gebottet, Maus angestöpselt: Dasselbe Ergebnis. Auch vice versa.
Noch ein Beispiel: USB-Laufwerk. Anstöpseln, Frage nach Treibern:
Auswahl des entsprechenden Verzeichnisses auf CD (Treiber nebst
.inf-Datei ist dort vorhanden) - aber Treiber (und .inf-Datei) wird
als "nicht vorhanden" reklamiert. Auch die dezidierte Eingabe des
Pfads mit .infs-Dateibezeichnung führt zu "Treiber nicht gefunden".
Ich denke, daß dieser Befund eindeutig insofern ist, als es _nicht_ an
den Treibern liegt.
Quoted text here. Click to load it

Entschuldigung, aber klugsch... kann ich selbst auch ganz gut. Das
Anstecken einers Kabels, das an seinem anderen Ende nur eine offene
Buchse hat, ist grds. o.k. - und wenn es ein USB-Kabel ist erst recht,
da ja USB-Geräte während des Betriebs an- und abgestöpselt werden
dürfen.
Beste Grüße

Dr. Michael König
--
    RA Dr. M. Michael König * Anwaltskanzlei Dr. König & Coll.
          D-65843 Sulzbach/Ts. * Antoniter-Weg 11
We've slightly trimmed the long signature. Click to see the full one.
Re: USB-Problem


Quoted text here. Click to load it

Hallo!

Das mit der Reaktion sollte normal sein, die USB-Prots reagiern schon
mal
auf die paar PF Kabelkapazität, wenn ich mich recht erinnere.
Auf Verdacht: Tauschen Sie doch mal die beiden
Data-Leitungen,kaputtgehen
kann ja nix ;-)
evtl. auch mal nachmessen, ob an der USB-Buchse die 5V und die Masse
an der richtigen Stelle sind, schonmal sind auch die Farbkodierungen
für den Eimer, vor allen Dingen bei so Billigware wie Adapterblechen...

MfG, Michael Buchholz.



Re: USB-Problem

Quoted text here. Click to load it

Ich habe auch nicht vor irgendwas zu unterstellen, aber ich kann
nur auf das antworten was ich hier lese, und aus Ihrer Anfrage war
nicht zu ersehen, das schon irgendwelche gerätespezifische Treiber
installiert wurden.

Quoted text here. Click to load it

Das ist aber bei USB etwas unüblich, obwohl es da gelegentlich auch
so funktioniert...
Normal stöpselt man das Gerät an, dann wird ein "Unbekanntes Gerät"
erkannt und anschließend kommt ein Fenster über das man den Treiber
für das Gerät installiert.
Wenn das Gerät dann immer noch nicht läuft kann es auch sein,
daß das Bios die Schnittstelle nicht richtig eingerichtet hat,
der IRQ, den sie verwendet sollte erst mal nicht von einer
anderen Hardware verwendet werden, vor allem bei Win98 war das
IRQ-Sharing noch nicht ganz ausgereift.

Quoted text here. Click to load it

Wenn Sie so überzeugt sind, daß es an der Hardware liegt, dann
untersuchen Sie doch mal diese. Die einfachste Variante ist man
besorgt sich die Belegung des Steckers auf den Board, den findet
man oft im Board-Handbuch, und danach klingelt man den Adapter
durch. Das alle Adapter, die gleich aussehen auch gleich sind,
ist bei weiten nicht der Fall, ich habe selber zwei hier, bei
denen die Daten-Anschlüsse (D+/D-) vertauscht sind.

Quoted text here. Click to load it

USB-Stecker haben grade dafür einen entsprechend große Masse-
Anschluß, der kleine Board-Stecker hat den nicht.

Frank


Re: USB-Problem
Am Tue, 20 Jan 2004 22:23:36 +0100, meinte Frank Müller

Quoted text here. Click to load it

Doch. Ausdrücklich:
"Ich muß an einem älteren MB (HOT-553 von Shuttle, USB-taugliche
Intel-Chipsatz-Version, Win98SE) einen USB-Card-Reader (Tevion 6in1)
betreiben. USB ist im BIOS aktiviert, Treiber installiert, USBREADY
                                      ^^^^^^^^^^^^^^^^^^^^
von Intel meldet dreimal grün (BS, Hardware, Treiber). In der "

Quoted text here. Click to load it

Das mag sein. In allen entsprechenden Veröffentlichungen ist aber
genau dies dringend empfohlen; die umgekehrte Vorgehensweise
funktioniere nicht.

Quoted text here. Click to load it

Ich lasse mich gern vom Gegenteil überzeugen, aber wenn kein einziges
bei anderen PC funktionierendes USB-Gerät als solches (individuell)
erkannt sondern immer nur als "unbekanntes Gerät" eingetragen wird,
bleibt kein anderer Schluß übrig.

Quoted text here. Click to load it

Das habe ich natürlich schon längst getan. Ich frage hier nicht ohne
Grund und sicherlich nicht, um den Datendurchsatz zu erhöhen.

Quoted text here. Click to load it

Auch das habe ich probeweise schon getan.

Beste Grüße

Dr. Michael König
--
    RA Dr. M. Michael König * Anwaltskanzlei Dr. König & Coll.
          D-65843 Sulzbach/Ts. * Antoniter-Weg 11
We've slightly trimmed the long signature. Click to see the full one.
Re: USB-Problem

Quoted text here. Click to load it

Das ist nun mal die Vorgehensweise von Win98, alles was es
nicht selbst kennt ist ein "unbekanntes Gerät", erst wenn
der Treiber für das Gerät installiert wird kommt auch der
richtige Gerätename da hin.
Da Sie immer wieder anbringen das ein "unbekanntes Gerät"
gefunden wurde, wird wohl irgendwo noch ein Treiber fehlen,
denn sonst wäre das Gerät nicht unbekannt.

So lange "unbekannte Geräte" auftauchen fehlen Treiber, oder
ist irgendwas anderes an der Software, nicht in Ordnung eine
Frage in microsoft.public.de.german.win98.allgemein dürfte
da schneller zum Ziel führen.

Frank


Site Timeline