newbie probs with ARM7 eb40a eval board (Hitex Tantino)

Do you have a question? Post it now! No Registration Necessary

Translate This Thread From English to

Hi,

I'm doing my first steps with the ARM7 AT91R40008. I'm using the EB40A
Eval Board by Atmel and  the Hitop (with Tantino ARM)  environment.
I tried loading an example application onto the controller, but even
while opening the project, there were errors (Hiscript error, Code 37),
something about missing script files.
When I tried downloading the app onto the controller, I also received
error messages, presumably because of the same missing script files
(startup script?).
I tried erasing the flash, as suggested in the quick start guide by
hitex, but the procedure returned the following error:

"The flash algorithm didn't run properly in target. This could happen
due to the following reasons:
- the specified RAM space is not accessible.
- wrong JTAG settings. Load target code.

After this, I got the tip of using the StartEasy application by Hitex
to generate an example program. I compiled the example "blinky" and
opened the project in Hitop. This time, there were no script errors. I
still can't clear the flash and most confusingly, there are 2 Flash
Eeproms listed, when I first opened the project. I had to delete the
lower one (0x00000000-0x011FFFFF) before the download worked. I
downloaded it, but the best result I got was a slight dimming of the
chosen LED. It looks like there's something else also triggering the
LED.

So, I'm quite idea-less at the moment

anybody can help?

thanks a lot

Claudia


Site Timeline