Perl version conflict over an RPM install

I'm trying install LMS (Logitech Media Server) on a laptop running Fedora
28, like all my other hosts (apart from an RPi, which runs Raspbian).
LMS is a Perl application, hence the title.
The target machine is running Fedora 28, fully updated as of last Friday,
and and has never had LMS installed on it. I tried both the standard
release version, built last April, and the nightly development version,
built on Tuesday. These are:
logitechmediaserver-7.9.1-1.noarch.rpm 17-Apr-2018 08:28 171M
logitechmediaserver-7.9.2-0.1.1536072399.noarch.rpm 171.37 MB
September 04 2018 15:22
However, a straight-forward install of either .rpm fails immediately with
a Perl version dependency error. Here's the standard release failing to
install, followed immediately by asking Perl for its version:
$ sudo rpm -U logitechmediaserver-7.9.1-1.noarch.rpm
[sudo] password for xxxx:
error: Failed dependencies:
perl >= 5.8.8 is needed by logitechmediaserver-7.9.1-1.noarch
$ perl -v
This is perl 5, version 26, subversion 2 (v5.26.2) built for x86_64-linux-
thread-multi
...
$
As you can see, the current F28 Perl is version 5.26.2, and since LMS
only requires 5.8.8 or higher, I would have expected that to work, but
noooo...
This will be a throwaway install which will be used as a known fresh
install while I trouble-shoot a plugin problem with my live LMS server,
which is on a different host, so I don't mind trashing it by tweaking the
rpm options to force an install. If it runs as well, that's a bargain.
With that in mind, how can I force rpm to ignore the Perl version and do
the install anyway?
I'd prefer to force rpm to do the install rather than using a nightly
tarball because that will make removal easier when I no longer need this
copy of LMS.
--
Martin    | martin at 
Gregorie  | gregorie dot org
Reply to
Martin Gregorie
Loading thread data ...
man rpm
I would try with --force and/or --nodeps
Bye Jack
Reply to
jack4747
Could be a bug where the versions are compared lexically instead of numerically.
Reply to
A. Dumas
As you multi-posted, rather than cross-posted, my answer is over in u.c.o.linux
Reply to
Andy Burns
Yes, I knew that: I'm currently using both the albasani and eternal- september servers and the prime one (seems to be albasani) wouldn't let me cross-post (said it had never heard of u.c.o.l), so I duped the post.
Reasoning was that u.c.o.l is a better/more logical place for RHF questions but c.s.r has far more traffic at present.
--
Martin    | martin at 
Gregorie  | gregorie dot org
Reply to
Martin Gregorie
Thanks for your help, guys.
--
Martin    | martin at 
Gregorie  | gregorie dot org
Reply to
Martin Gregorie
Following up:
rpm -U --force
didn't bypass the perl version mismatch, but --nodeps allowed the install to complete but didn't set up a link that the LMS forum thinks necessary, so I added that manually. After this the LMS server came up after I'd used systemctl to enable and start it and is currently busy building its local music catalogue.
I've posted an account of this to the LMS forum, suggesting that they fix the rpm dependency info and add a script to put the missing link in place.
--
Martin    | martin at 
Gregorie  | gregorie dot org
Reply to
Martin Gregorie

ElectronDepot website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.