Problem getting USB keyboard to catch new eventX que

Do you have a question? Post it now! No Registration Necessary

Translate This Thread From English to

Hi experts,

I have run into a problem with my USB keyboard on an ARM9 based
embedded linux version  The USB keyboard works nicely and are
connected to the /dev/input/eventX que when inserted into the USB plug.
However each time i plug the keyboard it is connected to a new eventX
number (the next free number).

The problem is that after having plugged the keyboard some times there
are no longer any free eventX number and the keyboard stops working. On
my PC running linux the keyboard gets the same eventX number each time
but on the embedded linux it seems to run through the event ques until
no more free ques.

I have loaded usbcore, ohci-hcd, and tried both usbkbd and the newer
usbhid, same thing happens for both keyboard drivers.

I even tried making 32 eventX nodes (using mknod) but then it just
takes longer to run into the problem, i.e. after 32 insertions no more
USB keyboard :-(

Why is this ?
Do i need any additional drivers ?

Hoping for a prompt reply as we are soon to release the product :-(


Site Timeline