Pidora keyboard problem

Hi,
I'm running into a weird problem. I normally run Raspbian on my Pi,
but a while back I NOOBS'd an SD with Pidora and Arch. Never played
much with it, but I dragged it out again to see what I could get
working.
Yesterday, I booted into Pidora, and found that things worked, except
the NetworkManager was apparently interfering with my static connection.
With a bit of adjustment of ifcfg-eth0, I got this working reliably,
but I realized that the SSH keys were of course different from my other
SD, so -- with the Pidora SD in my laptop, I copied over the raspbian
keys. (Thought this would be safe -- even if I blew SSH, I didn't
change anything in the USB area.)
Rebooted Pidora. The login window wouldn't handle anything I typed in!
Mostly it wouldn't detect the keystroke, but other times it went into
continual repeat.
Thought maybe the keyboard had gone bad, but I tried both the Raspian
SD and the Arch on the same card. No problems.
So, maybe I *had* muffed my file copying. I went right back to NOOBS
and reinstalled Pidora (with Raspbian this time, as I doubt I'll ever
use Arch).
Installation of Pidora got to "First Boot", but it wouldn't respond
to the K/B at all. (Mouse cursor was OK.) Had to pull the plug...
(:-() Switching over to Raspbian went perfectly again.
Any suggestions?
Thanks,
-- Pete --
Reply to
Pete
Loading thread data ...
Pete, You may want to try a different power supply.
I know this sounds odd, but I had similar symptoms on my Pi when I first set it up. I tried all of the different distros and some would hang at boot while others would run. I replaced the USB cable on my power supply and everything was (and still is) fine. I can only surmise that different distros enable different bits of the hardware and have different power requirements.
be seeing you ... Don
Reply to
Don
Other than laugh at then completely forget and never try Pidora even again...
If you're using a B+ then that needs a relatively recent kernel - otherwise the USB won't work for various reasons. I've no idea what kernel Pidora ships with but if it's not a new ish one then it won't work on a B+
Gordon
Reply to
Gordon Henderson
Dzieki, Gordon, za post o tresci:
Pidora has raspberrypi-kernel-3.12.23-2.20140626git25673c3.rpfr20.armv6hl
--
Tomasz Torcz               "Never underestimate the bandwidth of a station 
xmpp: zdzichubg@chrome.pl    wagon filled with backup tapes." -- Jim Gray
Reply to
Tomasz Torcz
I'd rather believe this isn't the problem... (:-/)
It's a solid 1A supply (that was part of the Element14 kit). I have nothing extra hung on except the K/B and mouse, so there should be no loading problem. And I've never run into anything like this with any of the other setups I've tried.
-- Pete --
Reply to
Pete
That may just be the best option... (:-)) My Linux use started way back with Red Hat, though, so I thought it might be familiar. (I have no problem with Debian, though I'm not fond of Ubuntu on my laptop.)
No, it's a standard Model B (and the NOOBS post dates it).
What's puzzling is that I never noticed a problem when I *first* tried Pidora, and everything else still works fine.
Thanks,
--Pete --
Reply to
Pete
I use fedora on most of my systems but found sticking to raspian on my pi to be the best option. heck Linux is Linux & the differences between distros are should not be significant enough to get hung up over, to be honest I find working on 2 different flavours to be an advantage as it only increases my knowledge.
--
Your EMAIL is now being delivered by the USPS.
Reply to
alister

ElectronDepot website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.