No U-boot prompt on PPC440GP

Do you have a question? Post it now! No Registration Necessary

Translate This Thread From English to

I need help getting u-boot to display its interactive prompt. I posted
yesterday to the u-boot mailing list, but I haven't gotten a response yet.

I have an IBM/AMCC PPC440GP evaluation board ("Ebony").  I built u-boot
with gcc 3.4.4 by issuing

    make EBONY_config
    make

which built u-boot without any errors. I did not modify the
configuration header file at all. The default disables automatic boot,
so I should just get a prompt.

I wrote the resulting u-boot.bin file to flash using a JTAG programmer.
I set the DIP switches and jumpers according to the README.ebony
instructions. When I turn on the power, it displays some console text
and then stops without a prompt. The console text is as follows:

----begin console output-----
U-Boot 1.1.2 (Jul  6 2005 - 15:51:04)

IBM PowerPC 440 GP Rev. C
Board: IBM 440GP Evaluation Board (Ebony)
         VCO: 600 MHz
         CPU: 300 MHz
         PLB: 100 MHz
         OPB: 50 MHz
         EPB: 50 MHz
I2C:   ready
DRAM:  I2c read: failed 4
I2c read: failed 4
128 MB
-----end console output-----

Nothing more happens. No prompt is displayed. I tried the J41/J42
bootstrap corruption directions, but it did not seem to have any effect.

If I press the reset switch, I get the same output as when I power up,
except that the last line (128 MB) is not generated.

I assume the I2c read failures are not normal, but I am not sure. Could
someone suggest what to do next?

Thanks.

Gregg

Site Timeline