Mega Atmel 32 ISP Problem

Do you have a question? Post it now! No Registration Necessary

Translate This Thread From German to

Threaded View
Hallo,

mein nagelneuer Mega-Atmel32 laesst sich leider nicht programmieren.
Ich habe mir dazu das serielle Kabel mit den Z Dioden fuer Ponyprog
gebastelt und entsprechend am Mega32 angeschlossen. Wie es aussieht
werden die /Reset, SCK und MOSI Leitungen korrekt angesteuert (mit
Oszi angesehen) der Atmel gibt aber nix an MISO aus (manchmal kommt
ein kleiner Stoerimpuls raus < 0.5V). Ich habe sogar einen externen
Takt angelegt (12MHz) der aber auch keine Verbesserung brachte. Ist
IMHO aber auch nicht noetig, da im Auslieferungszustand der interner
RC Oscillator benutzt wird.
In meiner Verzweifelung hab ich dann noch einen Adapter fuer den par.
Port mit nem 74HCT244 Buffer-chip gebastelt, aber leider das selbe
negative Resultat -> Stille an MISO.

Weiss jemand Rat? Ich hab gelesen dass man sich Mega8 chips in
Verbindung mit Ponyprog unbrauchbar machen kann, konnte aber nix
finden warum und wie. Kann sowas mit Mega32 auch passieren?
 
Bin fuer jede Hilfe dankbar,
Andre

Re: Mega Atmel 32 ISP Problem
Andre Fisser schrieb:

Quoted text here. Click to load it

Du hast dran gedacht, daß [alle|bestimmte] Megas über RxD und TxD und nicht
über MISO und MOSI programmiert werden?

Gruß
Henning
--
henning paul home:  http://www.geocities.com/hennichodernich
PM: snipped-for-privacy@gmx.de , ICQ: 111044613


Re: Mega Atmel 32 ISP Problem
Hi!

Quoted text here. Click to load it
nicht
Nein, den AtMega32 programmiert man über Mosi/Miso/Sck. Außer wenn man nen
Bootloader drin hat. Aber soweit ist der OP ja noch nicht.

@Andre :Guck doch mal, ob du jemand mit nem sicher funktioierendem
Programmer in deiner Nähe findest. Am Besten ein STK500. Hast du zufällig
noch was anderes an diesen Portpins angeschlossen? Das könnte auch Probleme
geben. Falls du tatsächlich die Fuses umprogrammiert hast, könnte noch ne
Programmierung übers JTAG-ICE (clones gibts bei www.olimex.com)
funktionieren.

mfg
Jan



Re: Mega Atmel 32 ISP Problem
Jan Stumpf schrieb:

Quoted text here. Click to load it

Ok, bei meinem ATmega128 hatte ich mich nur etwas gewundert. Andere ATmegas
sind mir noch nicht in die Finger gekommen, habe noch Restbestände von
Classic-AVRs. :-)

Gruß
Henning
--
henning paul home:  http://www.geocities.com/hennichodernich
PM: snipped-for-privacy@gmx.de , ICQ: 111044613


Re: Mega Atmel 32 ISP Problem
Quoted text here. Click to load it

Hallo Jan,

kenn leider niemand mit nem funktionierenden Programmer ;-(
An den Pins ist nix anderes dran. Mein "Testboard" besteht eigentlich
nur aus dem Atmel + Kondensator fuer Vdd, Quartz-Oscillator und den
ISP Header. Meine Idee war nach und nach die restliche Hardware
"dranzuflicken". Aber erst will ich dass Ding programmieren koennen!
Aber die Idee mit dem JTAG gefaellt mir. Haette dann auch den Vorteil
dass das Debugging einfacher wird. Hat schon jemand Erfahrung mit der
Firma "olimex"? Taugt dass JTAG ding ueberhaupt was? Der
Preisunterschied zum original Atmel JTAG Interface ist ja schon
extrem, wo ist da der Haken?

Gruesse,
Andre

Re: Mega Atmel 32 ISP Problem
Hi Andre!

Quoted text here. Click to load it
falls du aus München kommst, kannst du vorbeikomemn ;)

Quoted text here. Click to load it
Was hat du nochmal für einen Programmer?

Versuch mal folgendes mit einem kurzen Kabel :

Parallelport
Pin Bedeutung          Belegt mit
------------------------------------------------
 1  STROBE             RESET
 2  D0                 SCK
 6  D4                 MOSI ( Daten an Device )
10  ACKNOWLEDGE        MISO ( Daten von Device )
18-25 GND              GND

ein GND-Pin reicht!

(von www.digital-hobby.de)

an Mosi und Sck solltest du nen 100Ohm in Serie schalten. Funktioniert bei
mir super mit vielen verschiedenen Atmels. Die Schaltung ist kompatibel mit
dem Kanda-Programmer. z.b. sp12 (www.digital-hobby.de) kann nach einer
Änderung im Configfile (siehe Doku) damit umgehen! evtl. brauchst du dafür
noch ein Devicefile für den Atmega32. Schreib mir dann einfach ne Mail.

Quoted text here. Click to load it
also olimex ist gut. Und selbst der Support ist super! Ich hab da allerdings
bis jetzt nur Platinen machen lassen. Das Jtag-Ice ist intern nichts anderes
als ein Atmega169 (oder so) mit dem entsprechenden Programm und Bootloader
drauf. Bei der Olimex-Variante könnte es sein, daß ein paar Schutzfunktionen
fehlen (keine Buffer and den I/Os). Ich kenne jemanden, der das JtagIce mal
nachgebaut hat. Das soll wohl super funktionieren. Bei dem Preis würde ich
das Original nicht mehr kaufen! Ich selber habe das Original und bin auch
total zufrieden.

mfg
Jan



Re: Mega Atmel 32 ISP Problem
Am 16.02.04 15:29 schrieb Andre Fisser:

Quoted text here. Click to load it

Wie lang ist dein Kabel? Bei mir war bei den Megas nach mehr als zwei
Metern Schluss. Ich hab dann einen Max232 zwischen AVR und Kabel
gehängt, danach gab es keine Probleme mehr. Wie schaun denn die Flanken
direkt am AVR aus?

Gruß
Michael

Re: Mega Atmel 32 ISP Problem
Hi Michael,

Quoted text here. Click to load it

Also die Flanken sehen ganz gut aus; steil, keine Ueberschwinger,
allerding was mir an dem seriellen Dongle nicht gefaellt ist dass der
Low-Level negativ (-0.7V) ist. Aber dass muss wohl so sein.
Der Programmer selbst hat nur ca. 30cm Kabel, allerding betreib ich
ihn an ein ca. 2m langes "Verlaengerungskabel". Ich werd heute mal
hinter meinen PC kriechen und das Ding ohne Verlaengerung testen, ich
glaub aber nicht dass es daran liegt.

Andre

Re: Mega Atmel 32 ISP Problem
snipped-for-privacy@web.de (Andre Fisser) schrieb:

Quoted text here. Click to load it

Weil man sich durch flashces Setzen eines Fuse-Bits den /RESET Eingang
wegdefinieren kann (zu einem normalen IO-Pin) und danach kein ISP mehr
möglich ist.  Ponyprog ist ein wenig berüchtigt dafür, daß Leute sich
damit die Fuses zerschießen, da diese bei Atmel ,,negative Logik''
haben (EPROM-Logik halt, ein gelöschtes Bit hat eine 1) und Ponyprog
daß offenbar etwas zweideutig auf die Nutzer durchschlagen läßt.

Quoted text here. Click to load it

Mußt Du ins Datenblatt gucken, ob es eine RSTDSBL Fuse gibt, meiner
Erinnerung nach nicht.  Wenn ich mich recht entsinne, gibt's außer
dem ATmega8 nur noch einen ATtiny, der sowas macht.

--
Jörg Wunsch

"Verwende Perl. Shell will man können, dann aber nicht verwenden."
We've slightly trimmed the long signature. Click to see the full one.
Re: Mega Atmel 32 ISP Problem
Hallo Joerg,

snipped-for-privacy@ida.interface-business.de (Joerg Wunsch) wrote in message
Quoted text here. Click to load it

Ach so; soweit bin ich ja noch nicht gekommen. Aber stimmt schon,
Ponyprog ist echt verwirrend bei den Fusebits.

Quoted text here. Click to load it

Hab nachgesehen, der Mega32 hat kein RSTDSBL fusebit.
Dass ist es also nicht, da bin ich schon mal beruhigt!

Andre

Re: Mega Atmel 32 ISP Problem
snipped-for-privacy@web.de (Andre Fisser) wrote in message
Quoted text here. Click to load it


Hi!

Habe festgestellt, dass für die AVR's mit A/D-Wandler die Pins für die
Referenzspannung gültig versorgt werden müssen. Habe für diese Fehler
einige sinnlose Stunden verloren. Dies ist auch dann nötig, auch wenn
Du gar keinen A/D-Wandler nützt.
LG aus Wien

Site Timeline