TV tunes all channels but not properly.


Teak TV ct-M687;HDTV Any advice please.
All channels can be somewhat tuned but none of them look good.
Picture is distorted/wavy and the sound cuts in and out for about 5
minutes from when TV is first turned on.
I have tested with a VCR and cannot receive stations from the RF but
this is confusing me: I switch the VCR to test and can get the 2
vertical white lines by tuning the TV to channel 3 (via RF) but cannot
receive anything.
However I do get perfect picture and sound via the scart connector.
So far I have resoldered etc.; I have B+ at 12.11v and various voltages
on other pins at the tuner but no reading on the IF pin.
I would appreciate any thoughts on narrowing down the problem.
Thanks
ALI
Reply to
alitonto
Loading thread data ...
alitonto ha escrito:
sounds like you need to check the I.F. section for bad caps and/or the aft may need a tweak. B.
Reply to
b
I am not sure how to check the IF section because I cannot get a reading with my digital meter on the tuner's IF pin. Is it possible to measure some DC volts there or only frequency can be measured? I have checked and replaced marginal caps so far. Ali.
b wrote:
Reply to
alitonto
The 2 DC voltage checks I can think of are the AFT (* VDC or so, if memory serves) and the B+ (33 VDC).
I've seen weak tuners that couldn't produce a good image for cable signal levels, but a video game deck was okay. Perhaps the test signal from your VCR is a stronger signal, and the tuner is marginal. As a test (not a repair) try an RF amplifier.
Tom
Reply to
Tom MacIntyre

ElectronDepot website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.