Strange error when extracting the current version of Crosstool, only happens on Linux

Do you have a question? Post it now! No Registration Necessary

Translate This Thread From English to

Hello from the confused Timelord
I need to build a crosscompiler for the SH family of processors. So I
found and downloaded the excellent tool that Dan Kegel created. Under
Cygwin it extracted correctly. I haven't tried to use it under Cygwin,
but I have used it before under Linux, Slackware Linux in fact. This
happens under the current release 10.2:

tar: crosstool-0.38/patches/gcc-3.3.2: Directory renamed before its
status could be extracted
tar: crosstool-0.38/patches: Directory renamed before its status could
be extracted
tar: Error exit delayed from previous errors

It happend with both the freshly downloaded file, and then earlier with
one that I was going to use under Cygwin, that one I pulled over using
the Samba server. Essentially I received the exact same error message.

For Slackware this is tar (GNU tar) 1.15.1. And Gzip is gzip 1.3.3
(2002-03-08).

For Cygwin this  is tar (GNU tar) 1.15.1. And Gzip is gzip 1.3.3
(2002-09-30). Although I suspect that there might be something special
about those programs for Cygwin.

Any suggestions people?
--
Gregg gregg dot drwho8 atsign gmail dot com


Site Timeline