LTspice - Error message:"Too few parameters"

Do you have a question? Post it now! No Registration Necessary

Translate This Thread From English to

Threaded View


Hello,

I created a symbol for the 74HC367 and a .sub-file from an
74HC.lib-File from Orcad. When I want to run the simulation, the
following error message occurs:

 "Too few parameters for subcircuit type "74hc367" (instance: xu1)"

Here is the .sub-File:

*---------
* 74HC367  Hex Bus Drivers with 3-STATE Outputs
*
* The High-Speed CMOS Logic Data Book, 1988, TI
* atl     7/18/89        Update interface and model names
* rbh   11/11/92    Added bus I/O model
*
.subckt 74HC367  1A1 1A2 1A3 1A4 2A1 2A2 G1BAR G2BAR 1Y1 1Y2 1Y3 1Y4
2Y1 2Y2
+    optional: DPWR=$G_DPWR DGND=$G_DGND
+    params: MNTYMXDLY=0 IO_LEVEL=0
UINV inva(2) DPWR DGND
+    G1BAR G2BAR   G1 G2
+    D0_GATE IO_HC IO_LEVEL=
U1 buf3a(4) DPWR DGND
+    1A1 1A2 1A3 1A4   G1   1Y1 1Y2 1Y3 1Y4
+    D_HC367 IO_HC_BUS MNTYMXDLY= IO_LEVEL=
U2 buf3a(2) DPWR DGND
+    2A1 2A2   G2   2Y1 2Y2
+    D_HC367 IO_HC_BUS MNTYMXDLY= IO_LEVEL=
.ends
*
.model D_HC367 utgate (
+    tplhty12%ns    tplhmx24%ns
+    tphlty12%ns    tphlmx24%ns
+    tpzhty26%ns    tpzhmx48%ns
+    tpzlty26%ns    tpzlmx48%ns
+    tphzty21%ns    tphzmx48%ns
+    tplzty21%ns    tplzmx48%ns
+    )
*$

How can I solve this problem?

Many thanks in advance.
Robert


Re: LTspice - Error message:"Too few parameters"


Quoted text here. Click to load it


Hello RDA,

LTspice is compatible to PSPICE at "analog" devices but not for digital
devices.
The devices for digital circuits are totally different among all SPICE
programs.

In LTspice you should use the A-devices for digital parts.
You can find a lot about it in the help pages of LTspice.

There are many examples for digital circuits in the "Files"-section of the
Yahoo group.
Just do a search for "digital".
 http://tech.groups.yahoo.com/group/LTspice /
Please join this group. You will be surprised about the activity of this
group and
the many examples in their "Files"-section.

Best regards,
Helmut


Quoted text here. Click to load it



Re: LTspice - Error message:"Too few parameters"


Helmut Sennewald schrieb:

Quoted text here. Click to load it

Hello Helmut,

thank you for the hint with the A-Devices. I know the group for some
month, but I didnt find anything about this problem. But now I will try
your suggestions.

Best regards,
Robert


Site Timeline