Trouble while running linux on custom PPC405GP board

Do you have a question? Post it now! No Registration Necessary

Translate This Thread From English to

Threaded View
Hello All !
I'm new in embedded linux and trying to run linux (2.4.22) on PowerPC
(405GP). It boots nice, but when it tries to execute /sbin/init it
hangs. Last console messages
are:
.......
VFS: Mounted root (nfs filesystem).
Freeing unused kernel memory: 56k init 4k prep

I've tried to replace /sbin/init by my own executable - it's
definitely have
not been executed.
I've traced it to the "last point" in kernel-mode (instruction "rfi"
in file
arch/ppc/kernel/entry.S:389). Everything OK before this point. But
after this step kernel just hangs.
After this sysrq-t prints that process init are running at c0007190
(this is
in the arch_kernel_thread).
sysrq-p doesn't print any registers, just the line "SysRq : Show
Regs".

Could someone give me any tips how to handle this trouble?

Re: Trouble while running linux on custom PPC405GP board

Quoted text here. Click to load it

Is the NFS file system OK?
Up to this point you have been running from the kernel image.
But your init executable is probably on the NFS remote filesystem.

/RogerL

PS
        ELDK is a distribution for embedded systems (PowerPC, ARM, ...)
        http://www.denx.de/ELDK /
DS

Re: Trouble while running linux on custom PPC405GP board
Hi,
Quoted text here. Click to load it

NFS Filesystem is OK. File "/sbin/init" successfully loads in memory (I've
checked this by examining contents of the memory). Problem occurs a bit later
- when kernel tries to switch to user-mode.

Re: Trouble while running linux on custom PPC405GP board
Are you trying to mount the root using nfs?

Shahar

Quoted text here. Click to load it



Re: Trouble while running linux on custom PPC405GP board
I ran into a similar problem once when I had a bad glibc.  I had
compiled the kernel for 386,  but the glibc still had 686 instructions
that hung on old uP architectures.

I had to recompile (cross-compile) the glibc after using the
# ./configure  <various --options I can't remember>
command to straighten it out.  

It's a maddening bug when you jump off into space like that!  
--- My random guess.  

Quoted text here. Click to load it

Site Timeline