MS-Dos 6.22 in PCemV15Win don't see CD-ROM drive when 1 partition + 3 logical partitions ?...

Do you have a question? Post it now! No Registration Necessary

Translate This Thread From English to

Threaded View
Hello,

I created 8 GB image with PCemV15, installed ms-dos 6.22 into it. Used WinI
mage to convert floppy images to img format also used it to insert addition
al files and fixes into iso's and such.

Used SCSI harddisk drive setting to install ms-dos 6.22 onto 8 GB harddisk,
 MS-DOS 6.22 creates first partition as 2 GB. (Later switched back to stand
ard IDE and used "auto" detect setting in bios, MS-Dos 6.22 still sees all  
partitions as 2 GB which so far is nice).

Then later I run F-DISK and creates 1 big extended partition, with 3 logica
l partitions into it, 2 GB, 2 GB and then some 1.8 GB remainder or so.

64 MB RAM is installed.

When MSCDEX loads it says Error: no CD-ROM drives detected at all.

Before creating these 4 partitions I read about ms-dos 6.22 limitations

https://msfn.org/board/topic/159631-testing-ms-dos-limitations/

This "guy" seems to imply that when 4 partitions are enabled, the cd-rom is
 prioritized if present and then only 3 partitions will be detected.

But in my situation the cd-rom is not detected at all, and all 4 partitions
 are detected.

Is there any way to fix this ? For example for ms-dos to detect CD-Rom or m
aybe hide the 4th partition ?

Maybe it's a bug in PCemV15, it has lot's of hardware emulation, so maybe I
 should pick something else.

I could also try and convert this IMG into a VMDK or VHD and test it in VMW
are 8 and VirtualBox to see how the 8 GB disk behaves there in relation to  
cd-rom drivers.

I kinda need the cd-rom to play batman forever iso and batman forever arcad
e versions. (I fixed the copy_bat.exe with tppatch, however it's still miss
ing fmv.ini but I just create that manually in it's game folder and then bo
th games work).

Not having CD-rom support would suck for games like C&C and others which mi
ght require the CD-rom to be present.

So far I find that PCemV15 has more beautifull sound reproduction than DOS-
BOX.

So I kinda prefer it when it's working, it's kinda slow, but also kinda coo
l.

Ofcourse I could eventually fall back to real computers/old once, but so fa
r it's nice to produce an IMG/virtual disk in Windows 7 to test and get the
 games working and such, without having to reboot a real computer constantl
y, and it just works a bit better/easier with windows explorer and such.

And still figuring out how to get the most out of ms-dos 6.22.

I know there is ms-dos 7.1 and such and fat32, maybe I will try that later,
 but I am used to ms-dos 6.22 and kinda want to push it's limit as far as p
ossible, without losing essential capabilities.

First I used the AMI 486 clone BIOS, but it has a long wait.

So far I have used AWARD SiS 496/497, I think this is the one my 80486 prob
ably has and is probably best, will have to check later, or maybe this is t
he one my pentium 166 has.

I think my 80486 actually has something else but not sure ;) :)

If you happen to know any solution, let me know ! ;)

I am basically using "ms-dos started pack" from Phil so it has good autoexe
c.bat and config.sys.

It did work on smaller disk, but for some reason does not work on current b
ig disk.

I deleted smaller disks, thinking I wouldn't be needing them, but I may hav
e to re-create which kinda sucks a bit.

But first I have to figure out what the exact problem is.

I got a little scared when I accidently created a 32 GB disk in this PCem t
ool, windows explorer starting freaking a little bit after I terminated it,
 it took a bit long, as I tried to delete it windows explorer freaked a bit
, ms-dos delete worked ok, I did a chkdsk just in case, but no errors found
.

Meanwhile I have moved these IMG files to a different folder away fro my ma
in file disk image folder, just to prevent any fuck ups/overwrites and such
.

So far it was quite fun to hear Mortal Kombat, Dune 2, Doom and so forth in
 this emulator.

Enabling dynamic recompiler helps a lot to make it faster I think.

Bye for now,
  Skybuck.

Re: MS-Dos 6.22 in PCemV15Win don't see CD-ROM drive when 1 partition + 3 logical partitions ? How to fix ?
OK, I solved already thanks to this posting, which gave me an idea:

https://www.techrepublic.com/forums/discussions/settingup-driver-to-access-cd-rom/

"
It doesn't appear that the system is seeing your cd-rom. If your cd is connected to your secondary ide controller go into your cmos settings and make sure that the secondary ide controller is set to auto detect. then make sure your cd-rom is listed
"

I went into PCem configuration and set the Primary Slave (D): to CDROM.

This will lead to detected by MSCDEX.

I setup it up explictly to install itself onto G:

Cause c,d,e,f is already taken.

This is probably not necessary but just in case:

/L:G

This witch will force it onto G drive.

I will now test what happens if this is left out.

OK when it is left out it also installs itself onto G.

So this is what I want, automatic assignment of cd-rom drive letter at the back of all other drives/partition in case I create even more partitions on some other disk sometime ! ;)

Sorry to bother you for nothing, but sometimes this happens and I find solution myself quickly just after a posting ! ;) :)

Bye,
  Skybuck.  

Re: MS-Dos 6.22 in PCemV15Win don't see CD-ROM drive when 1 partition + 3 logical partitions ? How to fix ?
However I did have to re-install Batman Forever ISO version, which is basically a Mortal Kombat version of Batman so I wanna see what it's like and if it's any good ;) :)

Since the game was installed on a smaller disk, and copied to the bigger disk, it was installed from cd-rom drive D cause the installation program asks where the cd-rom drive is, it's not smart enough to auto detect it.

So this prevented batman forever iso from starting, could not find cd-rom disk.

So I decided to re-install from G and this fixed it, the game now starts and sound is working, no music yet, not sure why, maybe game don't have music, or sound setup is wrong or maybe something else is wrong not sure yet.

Re-installing was kinda interesting because the installer went further than in vm-ware or dos-box, in dos-box it doesn't even work and files are 0 size when copied.

in PCem it asked to install vesa drivers for video clips and performed some high res modes, didn't seem to work those hi-res modes but so far so good, maybe later I may have to say NO to vesa not sure what will happen ;)

Bye for now,
  Skybuck.

P.S.: Time to play some batman forever iso ! =D See how far I get ;)

Site Timeline