ICD2 Clone - 4550 perd son programme quand on le branche !

Do you have a question? Post it now! No Registration Necessary

Translate This Thread From French to

Threaded View
Bonjour à tous,

J'ai un ICD2 Clone. Et je perds la programmation du 18f4550 qd je
branche ou je débranche le cable USB.
A partir du moment où je perds le programme, je suis obliger de remettre
le programme avec un pickit2. Car c'est fini, je n'ai plus jamais aucune
connection possible !
Je ne comprends pas pourquoi ca fait çà ...
Quelqu'un a déjà eu le pb ?

Merci

Stéphane

Re: ICD2 Clone - 4550 perd son programme quand on le branche !
Quoted text here. Click to load it

Une fois, j'ai eu l'un des deux µC - je ne me souviens pas lequel - de mon
clone d'ICD2 qui a été effacé lorsque je l'ai prêté à un ami sous apple. Du
coup, j'ai du le reprogrammer en copiant le firmware de son clone à lui (il
s'en était aussi acheté un), et le remettre dans le mien. Je n'ai pas non
plus compris ce qu'il a fait, et ça ne s'est plus jamais produit depuis.

Sinon, je pense que l'un des deux µC est reprogrammé au besoin des µC cibles
par MPLAB. Est ce que sur un autre MPLAB ça fonctionne ... ?

-- cLx

Re: ICD2 Clone - 4550 perd son programme quand on le branche !
cLx a écrit :
Quoted text here. Click to load it
En fait, c'est le 18f4550 qui répond plus à l'usb ...
Il est là juste pour faire la liaison usb vers 16f877.
Et je ne sais pas pourquoi , mais si je le débranche maxi 3 à 4 fois de
suite, la led qui doit être allumée sur l'ICD2 reste éteinte et c'est
fini, j'ai plus de dialogue USB ! Je remet le firmware dedand et il est
aussitôt détecté ... Le programme dans le 16f877 est toujours ok et je
ne l'ai pas encore reflasher pour l'instant et ca fait qd même 2 ans que
j'ai cet ICD2 ...
Je ne vois pas pourquoi cet 18f4550 s'efface tout seul !

Stéphane

Site Timeline