ADuC842BCP... Проблемы с кварцем...

Do you have a question? Post it now! No Registration Necessary

Translate This Thread From Russian to


Привет, ALL.

Использую ADuC842 в корпусе BCP...

Спаял плату... По опыту использования ADuC847-го часовой кварц припаял без
конденсаторов на землю...

Включил... Встроенная  PLL не смогла определить подключенный кварц... Отсюда
чип не работает на максимальной частоте ядра в 16.777216МГц.

Биты CD=0х00 не помогают. Только работают CD=0х01...

Читаю даташит, оказывается, этот адук может работать и без кварца... если
сильная стабильность не нужна...

Всё по даташиту, вот только почему-то чип не распознал припаянный кварц.
Как будь-то его нет на плате.

Отпаял кварц, всё работает. Чип программируется. Интересная фича!

Перепаял адук... Припаял кварц: из 4-х образцов адука, только один смог
определить, что кварц на плате!!!

Запустился и с битами CD=0x00. То есть стал работать на максимальной
частоте...

Далее... в даташите какая-то путаница насчёт конденсаторов на землю... в
847-ом есть внутренние конденсаторы на 12пФ... и внешние не требуются, я их
и не ставлю...

Здесь я даже и не подозревал, что схему эту изменят! В даташите пишут, что
конденсаторы надо, хотя есть внутренние на 18пФ...

В схеме оценочной платы от ADI написано, что конденсаторы в случае часового
кварца ставить не надо!

Путаница.

Когда кварц не определяется системой PLL, то осциллографом видно, как на
выходе генератора при подключенном кварце медленно возникает синусоида с
увеличивающейся амплитудой при касании щупом!

Далее... Решил проверить 842-ой при температуре +85 градусов...

При +58-ми градусах 842-ой остановился!!! Просто перестал встроенный
генератор генерить: на кварце наблюдаю уменьшающийся по амплитуде сигнал...
И при +58 градусах генерация на кварце прекращается! При остывании до этой
температуре генератор запускается...

Провёл те же испытания на 847-ом... Нагрел до 90 градусов... Проблем нет...

Вот такая история... Может быть, конечно, у меня конкретные образцы адуков
такие... Но вот вчера получаю письмо от одной девушки, которая тоже делает
систему на 842-ом... С описанием такой же проблемы... Когда кварц не
определяется... и чип работает на скорости 8.38Мгц...

Кто-нибудь сталкивался с такой работой 842-го?

Ваши мысли?







Site Timeline