Alimentation PIC - Page 2

Do you have a question? Post it now! No Registration Necessary

Translate This Thread From French to

Threaded View
Re: Alimentation PIC
Bon ...

j'ai trouvE9% d'ou venait le problE8%me.

Est fourni avec la carte un connecteur comme pour les piles 9 V
http://www.lelectronique.com/ressource/illustration/albums/Connectique/clip =
_9v.gif

Le miens que je possE8%de est inversE9% ... allez savoir pourquoi.

Donc en toute confiance j'ai branchE9% et ya donc une inversion de
polaritE9% qui s'est produite et qui ne se faisait pas avec les piles
qui elles E9%taient dans le bon sens.

Donc le soucis est reglE9%.

Pensez vous que jai pu causer des dommages E0% la carte et au pic ?
malgres le fait que tout ce monde E0% l'air de fonctionner ?

Merci E0% tous en tout cas

Emile le dE9%bile


Re: Alimentation PIC
On Sep 17, 12:26 am, Emile

Quoted text here. Click to load it
KAkIgVXUP4UA
Quoted text here. Click to load it

cLx++

J'avoue que l'inversion de polaritE9%, je n'y croyais pas.

Quoted text here. Click to load it

Oui, mais pour le coup, tu as un gage !


Re: Alimentation PIC
Quoted text here. Click to load it

Aie .... :( un gage :(

Penses-tu que mon nouveau jouet soit E0% moitiE9% mort suite E0% ce que je
lui ai fait subir ?? :)

Re: Alimentation PIC
Bonsoir,

c'est une erreur courante que de confondre la courant max qu'une alim
peut donner, et ce que l'appareil branché dessus va consommer.

donc si ca ne marche pas avec l'alim, ce n'est pas elle qui est en cause

perso j'aurai parié tout de suite à une inversion.

quand aux dégats, c'est déja bien si le pic fonctionne encore!

il y a toujours des diodes sur les portes mos, et ce sont elles qui sont
devenues passantes, et ont chauffé.

Il y a souvent sur les cartes, surtout d'experiomentation, une grosse
diode sur l'alim afin d'absorber les tensions inverese et qui vont
empêcher tout dégat. au pire c'est la diode qui cramera, son sacrifice
aura sauvé la vie du reste de la carte...

on peut supposer que le courant limité à 1 ampère a été absorbé par ces
diodes (protection, pic, ...) , d'ou un echauffement, mais pas forcémént
fatal.

maintenant, il n'est pas impossible qu'une e/s soit hs par exemple, ou
encore une autre fonction sur la carte, mais là, il n'y a qu'une façon
de le savoir: c'est de tester...

mais bon, je me veux rassurant, car c'est probablement le pic qui aurait
grillé en premier, tu as de la chance, car il m'est arrivé d'en brancher
à l'envers et je n'ai pas été aussi chanceux !!


Le 17/09/2010 00:26, Emile a Ă©crit :
Quoted text here. Click to load it
http://www.lelectronique.com/ressource/illustration/albums/Connectique/clip_9v.gif
Quoted text here. Click to load it


Re: Alimentation PIC


Là il n'est absolument pas question de bases à acquérir , je sais bien
que comparé à certains ici je suis une grosse quiche fumante dont
certains s'amusent et tant mieux :)
Je n'ai absolument rien branché sur cette carte elle sortait de
l'emballage , le pic était connecté sur la carte de programmation ,
son cordon USB son alim et rien de plus.
J'ai allumé l'alimentation et en posant mon doigt sur le pic et le
darlington c'etait brulant donc j'ai tout coupé et j'ai alimenté avec
mes 3 piles et lĂ  ca ne chauffait plus.
Emile l'imbécile.
===========
Ne prends  pas la mouche,  je n'ai pas voulu te froisser,  je n'ecris pas
qu'on est "imbĂ©cile"  mĂŞme si on ignore  "U=R*I"
 Mon conseil  dĂ©coule  de ce que tu as supposĂ© :
 <<< l'ampĂ©rage (de  l'alimentation) est trop fort   pour le PIC ? >>>
Qui laisse entendre que tu n'aurais pas posé cette question si tu
connaissais ces bases , qui  sont indispensables pour simplement connecter
un led , un relais à un µC.
Maintenant Si tu les connais , il  te suffi de les appliquer
Comme on te l'a dit , on commence par la vĂ©rification de la  [ tension ]
de
sortie de l'alimentation.  Si celle-ci est correcte  on cherche ailleurs  la
cause de ce type de dĂ©boire. et .. tu n'as pas fini d'en connaĂ®tre,  mĂŞme
quand tu seras très expérimenté
Bonne journée




Re: Alimentation PIC
Entendu MaiorE9%. :)

Une autre question ; j'ai mis dans le pic un programme de base qui
fait clignoter 3 leds sur les sorties 0 1 2 toutes les 10 ms.

Cela fonctionne mais il faut attendre plusieurs secondes avant que le
PICAXE execute le programme aprE8%s sa mise sous tension ; voici le
programme :

main:
label_10: high 0
pause 10
low 0
pause 10
high 1
pause 10
low 1
pause 10
high 2
pause 10
low 2
goto label_10

Je pensais que le programme s'E9%xecutait de suite E0% la mise sous
tension non ? Est ce une erreur de programmation ?
Comment faire pour que l'allumage se fasse E0% la mise sous tension et
cela sans dE9%lais ?

Merci beaucoup, des bisous E0% tous :)

Emile

Re: Alimentation PIC
On Sep 17, 9:37 am, Emile

Dans ton prgramme, E0% quelle durE9%e exacte correspond
Quoted text here. Click to load it
C'est des millisecondes ?

Quoted text here. Click to load it

Oui.


Non.

Mais vu l'E9%lectro-choc que tu lui a fait subir hier,
la fiabilitE9% de la carte (et du PIC) n'est plus garantie.

Quoted text here. Click to load it

Ca devrait : vE9%rifie la doc de ton PicAxe et du soft.
Il existe sur certains PIC un controle lors de la mise sous tension,
pour attendre la stabilisation de l'alim avant de dE9%marrer le
programme.
Mais ce dE9%lai est *largement* infE9%rieur E0% "quelques secondes" ...
Si ton montage doit etre alimentE9% sous 5 V, alimente-le bien sous 5 V.

Est-ce que ce dE9%lai se manifeste systE9%matiquement ?
Un test : tu mets l'alim, tu laisses tourner jusqu'au
clignotement des LEDs, puis tu redE9%marres le PIC
avec le bouton de RESET mais SANS COUPER L'ALIM :
dans ce cas, est-ce que tu as toujours ce dE9%lai ?

Re: Alimentation PIC
Quoted text here. Click to load it

Je fais le test et je te tiens informE9%.

merci

10 3D% 10 ms effectivement.

Emile

Re: Alimentation PIC
On Sep 17, 10:49A0%am, Emile

Quoted text here. Click to load it

| 10 3D% 10 ms effectivement.

Et tu as le temps de voir les LEDs clignoter ?

Re: Alimentation PIC

snipped-for-privacy@q2g2000vbk.googlegroups.com...
Entendu Maioré. :)

Une autre question ; j'ai mis dans le pic un programme de base qui
fait clignoter 3 leds sur les sorties 0 1 2 toutes les 10 ms.

Cela fonctionne mais il faut attendre plusieurs secondes avant que le
PICAXE execute le programme après sa mise sous tension ; voici le
programme :

main:
label_10: high 0
pause 10
low 0
pause 10
high 1
pause 10
low 1
pause 10
high 2
pause 10
low 2
goto label_10

Je pensais que le programme s'Ă©xecutait de suite Ă  la mise sous
tension non ? Est ce une erreur de programmation ?
Comment faire pour que l'allumage se fasse Ă  la mise sous tension et
cela sans délais ?
====================
Le PICAXE est un système "Ă  base de pic  prĂ©programmĂ©"  qui interprète les
instructions que tu lui fournis .
Son dĂ©marrage  qui nĂ©cessite des instructions de base , type du processeur ,
vitesse d'horloge, configuration de fonctionnement, déclaration des
variables  etc ...  est  programmĂ© de façon interne  des son alimentation,
cela demande "un certain temps " que tu ne peux contrĂ´ler
Lorsque tu crĂ©es un programme, il faut  compter sur ce fait , cela n'a pas
d'importance pour l'allumage de leds.
Si tu crĂ©es un programme de dĂ©tection inopinĂ©e quelconque,  par exemple
surveiller l'évolution d'intensité lumineuse avec une cellule photo
Ă©lectrique,  le  système doit rester  sous tension permanente  et le
programme tourner  en boucle ( En fait le µC il ne s'use pas plus hors
tension que  sous tension ..)
Bon après midi




Re: Alimentation PIC
Quoted text here. Click to load it

Ça dépend de la polarité de la tension en question quand même :)

(ok, je sors)

Re: Alimentation PIC
On Sep 17, 11:20 am, cLx

| En fait le B5%C il ne s'use pas plus
| hors tension que sous tension

Bigre !
Ce B5%C ne s'use pas, meme s'il est sous tension ?
Ou alors il s'usera, meme sans etre alimentE9% ?

Re: Alimentation PIC
Et si je veux un systE8%me qui se met E0% bosser dE8%s l'allumage ce n'est
donc pas possible avec PICAXE ?

Car lE0% le temps d'attente est de 5 secondes ce qui me parait E9%norme.

je refais de toutes maniE8%res les tests prE9%conisE9%s et reviens vers
vous.

Je n'avais pas reliE9% les E/S E0% des rE9%sistances de pull down ce qui
peut expliquer le temps d'attente peut etre.


Emile

Re: Alimentation PIC
On Sep 17, 11:43A0%am, Emile

Quoted text here. Click to load it

J'espE8%re que non, sinon c'est plutot mauvais signe.

Re: Alimentation PIC

Et si je veux un système qui se met à bosser dès l'allumage ce n'est
donc pas possible avec PICAXE ?

Car lĂ  le temps d'attente est de 5 secondes ce qui me parait Ă©norme.

je refais de toutes manières les tests préconisés et reviens vers
vous.

Je n'avais pas relié les E/S à des résistances de pull down ce qui
peut expliquer le temps d'attente peut etre.
===========
Effectivement   , 5 secondes cela fait  beaucoup .
Sauf si la notice le précise , les I/O non utilisés ( en général sortie
TTL  )  peuvent rester en l'air, mais  cela ne devrait pas ralentir
l'initialisation
Essaye un pgm plus simple  sans temporisation au dĂ©part
main:
high 4
pause 500
low 4
pause 500
goto main








Re: Alimentation PIC

Quoted text here. Click to load it
===========
Il a Ă©tĂ© dit   "Correctement connectĂ© "  inutile de prendre l'operateur pour
un neuneu,  le brochage  d'un composant  prĂ©cise  Vss,  VDD   et s'il se
trompe ....  c'est une autre histoire,  cela arrive mĂŞme aux inities



Re: Alimentation PIC
Quoted text here. Click to load it

C'Ă©tait une boutade, merci de l'avoir compris, le smiley c'est pas pour les
chiens.

Re: Alimentation PIC

Quoted text here. Click to load it
==============
Ach !   boutade   =   Mot d'esprit   ?
Alors  fĂ©licitations   pour cette   originale plaisanterie  :-X   :' )




Re: Alimentation PIC
Bon ,

Suite E0% ce message vous aurez l'envie forte de me lapider E0% coups de
microcontroleurs , de piles , de composants divers et je le
comprends !!

Sur ma platine d'essais il y avait le rE9%sonateur 4 mhz...

sur ma plaque d'essais y'avait pas le rE9%sonateur ...!

Voila !!

bonne nuit ... je m'en vais me gifler :)

Donc j'ai repositionnE9% le pic sur sa platine d'essais et ca marche
instantanE9%ment ...

Pensait que le resonateur E9%tait dans le pic moua ... !

Des bisous !!

Emile

Re: Alimentation PIC


Pensait que le resonateur Ă©tait dans le pic moua ... !
==============*
Cela aurait ete possible,  il existe des µC PIC   avec oscillateur incorporĂ©
....




Site Timeline