No graphic when loading "x11-gpe-image" for AT91SAM9263

Do you have a question? Post it now! No Registration Necessary

Translate This Thread From English to

Threaded View
I am working on AT91SAM9263ek board.I have made bootstrap,uboot and
kernel image for board.I am now trying to build rootfs(jffs2 image for
nandflash) image.I have used 2 links :
1)http://www.at91.com/linux4sam/bin/view/Linux4SAM /
OpenEmbeddedAngstromBuild#How_to_build_Angstrom_for_AT91

2)http://www.angstrom-distribution.org/building-angstrom

I have followed instructions given on those links.I have finall
executed command
bitbake x11-gpe-image and after waiting nearly 6-7 hrs i got jffs2
image.By using SAMBA i have transfered image on NANDFLASH.x11-gpe-
image does not start properly.
Only a black screen.gpe_dm is started and then nothing happens.
    i have made only 2 changes in config file i.e.stuff/build/conf/
local.conf
    MACHINE3D%"at91sam9263ek"
    DISTRO3D%"angstrom-2008.1"
please help me to get outof this.Please suggest configuration changes
if any.

thanks in advance.

this is what i got on hyperterminal:

RomBOOT
Quoted text here. Click to load it

U-Boot 2008.10 (Apr 14 2009 -
21:58:31)

DRAM:  64 MB
NAND:  128 MiB
In:    serial
Out:   serial
Err:   serial
Net:   macb0
macb0: Starting autonegotiation...
macb0: Autonegotiation timed out
(status3D%0x7849)
macb0: link down (status: 0x7849)
Hit any key to stop autoboot:  0

NAND read: device 0 offset 0xa0000, size
0x17f87c
 1570940 bytes read: OK
## Booting kernel from Legacy Image
at
   Image Name:   Linux-2.6.27
   Image Type:   ARM Linux Kernel Image
(uncompressed)
   Data Size:    1570876 Bytes 3D%  1.5
MB
   Load Address: 20008000
   Entry Point:  20008000
   Verifying Checksum ... OK
   Loading Kernel Image ... OK
OK

Starting kernel ...

Uncompressing
Linux.............................................................
......................................... done, booting the
kernel.
Linux version 2.6.27 (root@u810) (gcc version 4.3.2 (Sourcery G++ Lite
2008q3-72
) ) #6 Sat Apr 18 21:16:39
CPU: ARM926EJ-S [41069265] revision 5 (ARMv5TEJ),
cr3D%00053177
Machine: Atmel AT91SAM9263-EK
Ignoring unrecognised tag
0x54410008
Memory policy: ECC disabled, Data cache
writeback
Clocks: CPU 198 MHz, master 99 MHz, main 18.432
MHz
CPU0: D VIVT write-back cache
CPU0: I cache: 16384 bytes, associativity 4, 32 byte lines, 128
sets
CPU0: D cache: 16384 bytes, associativity 4, 32 byte lines, 128
sets
Built 1 zonelists in Zone order, mobility grouping on.  Total pages:
16256
Kernel command line: mem3D%64M
console3D%ttyS0,
ype3D%jffs2
AT91: 160 gpio irqs in 5 banks
PID hash table entries: 256 (order: 8, 1024
bytes)
Console: colour dummy device 80x30
console [ttyS0] enabled
Dentry cache hash table entries: 8192 (order: 3, 32768
bytes)
Inode-cache hash table entries: 4096 (order: 2, 16384
bytes)
Memory: 64MB 3D% 64MB total
Memory: 61584KB available (2904K code, 238K data, 136K
init)
Calibrating delay loop... 99.12 BogoMIPS
(lpj3D%495616)
Mount-cache hash table entries: 512
CPU: Testing write buffer coherency:
ok
net_namespace: 288 bytes
NET: Registered protocol family 16
AT91: Power Management
AT91: Starting after general reset
SCSI subsystem initialized
usbcore: registered new interface driver
usbfs
usbcore: registered new interface driver
hub
usbcore: registered new device driver
usb
NET: Registered protocol family 2
IP route cache hash table entries: 1024 (order: 0, 4096
bytes)
TCP established hash table entries: 2048 (order: 2, 16384
bytes)
TCP bind hash table entries: 2048 (order: 1, 8192
bytes)
TCP: Hash tables configured (established
2048
TCP reno registered
NET: Registered protocol family 1
NetWinder Floating Point Emulator V0.97 (double
precision)
JFFS2 version 2.2. (NAND) (SUMMARY)  A9% 2001-2006 Red Hat,
Inc.
msgmni has been set to 120
io scheduler noop registered
io scheduler anticipatory registered
(default)
atmel_lcdfb atmel_lcdfb.0: 150KiB frame buffer at 23940000 (mapped at
ffc00000)
Console: switching to colour frame buffer device
30x40
atmel_lcdfb atmel_lcdfb.0: fb0: Atmel LCDC at 0x00700000 (mapped at
c485c000),
i
rq 26
atmel_usart.0: ttyS0 at MMIO 0xfeffee00 (irq 3D% 1) is a
ATMEL_SERIAL
atmel_usart.1: ttyS1 at MMIO 0xfff8c000 (irq 3D% 7) is a
ATMEL_SERIAL
brd: module loaded
loop: module loaded
MACB_mii_bus: probed
eth0: Atmel MACB at 0xfffbc000 irq 21 (3a:1f:
34:08:54:54)
eth0: attached PHY driver [Generic PHY] (mii_bus:phy_addr3D%ffffffff:00,
irq3D%-1)
Driver 'sd' needs updating - please use bus_type
methods
NAND device: Manufacturer ID: 0xec, Chip ID: 0xf1 (Samsung NAND 128MiB
3,3V 8-
bi
t)
AT91 NAND: 8-bit, Software ECC
Scanning device for bad blocks
Bad eraseblock 256 at 0x02000000
Bad eraseblock 948 at 0x07680000
Creating 3 MTD partitions on
"atmel_nand":
0x00000000-0x00400000 : "Bootstrap"
0x00400000-0x04000000 : "Partition
1"
0x04000000-0x08000000 : "Partition
2"
atmel_spi atmel_spi.0: Atmel SPI Controller at 0xfffa4000 (irq
14)
usbmon: debugfs is not available
at91_ohci at91_ohci: AT91 OHCI
at91_ohci at91_ohci: new USB bus registered, assigned bus number
1
at91_ohci at91_ohci: irq 29, io mem
0x00a00000
usb usb1: configuration #1 chosen from 1
choice
hub 1-0:1.0: USB hub found
hub 1-0:1.0: 2 ports detected
usbcore: registered new interface driver
cdc_acm
cdc_acm: v0.26:USB Abstract Control Model driver for USB modems and
ISDN
adapter
s
Initializing USB Mass Storage
driver...
usbcore: registered new interface driver usb-
storage
USB Mass Storage support
registered.
usbcore: registered new interface driver
usbserial
usbserial: USB Serial support registered for
generic
usbcore: registered new interface driver
usbser
usbserial: USB Serial Driver core
udc: at91_udc version 3 May 2006
mice: PS/2 mouse device common for all
mice
input: gpio-keys as /class/input/
input0
ads7846 spi0.3: touchscreen, irq 31
input: ADS784x Touchscreen as /class/input/
input1
rtc-at91sam9 at91_rtt.0: rtc core: registered at91_rtt as
rtc0
rtc-at91sam9 at91_rtt.0: rtc0: SET
TIME!
i2c /dev entries driver
i2c-gpio i2c-gpio: using pins 68 (SDA) and 69
(SCL)
at24 0-0050: 256 byte 24c02 EEPROM
(writable)
Registered led device: ds1
Registered led device: ds2
Registered led device: ds3
usbcore: registered new interface driver
usbhid
usbhid: v2.6:USB HID core driver
Advanced Linux Sound Architecture Driver Version
1.0.17.
AC97C regs 3D% FFFA0000
AC97C irq  3D% 18
at91-ac97: codec write timeout
<4>at91-ac97: codec write timeout
<3>AC'97 0 access is not valid [0xffffffff], removing
mixer.
ac97c: probe of ac97c.1 failed with error
-5
ALSA device list:
  No soundcards found.
TCP cubic registered
NET: Registered protocol family 17
RPC: Registered udp transport
module.
RPC: Registered tcp transport
module.
rtc-at91sam9 at91_rtt.0: hctosys: unable to read the hardware
clock
VFS: Mounted root (jffs2
filesystem).
Freeing init memory: 136K
INIT: version 2.86 booting
Please wait: booting...
Starting udev
Populating dev cacheJFFS2 warning: (1125) jffs2_sum_write_data: Not
enough
space
 for summary, padsize 3D% -396

Root filesystem already rw, not
remounting
WARNING: Couldn't open directory /lib/modules/2.6.27: No such file or
directory
FATAL: Could not open /lib/modules/2.6.27/
modules
file or directoryCoul
Undefined users: Atmel AT91SAM92
Skipping /etc/default/volatiles/
99_hal
ALSA: Restoring mixer settings...sed tag 0x54410008
Configuring network interfaces... /usr/sbin/alsactl: load_state:1608:
No soundcanknown group "netdev" in message bus
co
rds found...
eth0      no wireless extensions.locks: CPU 198 MHz, master 99 MHz

udhcpc (v1.13.2) started
run-parts: /etc/udhcpc.d/00avahi-autoipd exited with code 1ogd:
done
CPU0: I cac
Sending discover...ociativity 4, 32 by
Sending discover...
Sending discover...
run-parts: /etc/udhcpc.d/99avahi-autoipd exited with code 1
CPU0: D cache: 16384 bytes, associativity 4, 32
No lease, failingts
done.
Starting portmap daemon: portmap.
[ ok ]

net.ipv4.conf.default
.
St
Checking for built-in Bluetooth: no

Configuring ppp-dialinm3D%64M console3D%ttyS0,-.
Configuring ttf-dejavu-sans-mono

NET: Registered pr
Configuring pango-module-basic-fc1695) PC3D%0x4018c
Configuring policykit
chmod: /var/run/PolicyKit: No such file or
directory
AT91: Starting after ge
Configuring gdk-pixbuf-loader-xpm
SCSI subsystem initia
Configuring ttf-dejavu-sans
Alignment trap: gpe-con
Configuring dbus
usbcore
 System startup links for /etc/init.d/dbus-1 already
exist.
usbcore: regist
Configuring hicolor-icon-themea3 FSR 0
Configuring ppp
|       |
 System startup links for /etc/init.d/avahi-daemon already exist.
table entries: 2048 (order: 2, 16384 bytes)----..-----.-----.
Configuring ttf-dejavu-common
Configuring ntpdate
TCP bind hash tabl
adding crontab (order: 1, 81
Configuring update-modules
Configuring gdk-pixbuf-loader-gifes configured (established 2048
Configuring libnss-mdns
atm
WARNING: Couldn't open directory /lib/modules/2.6.27: No such file or
directory

at91sam login: sdf
Starting system message bus: dbus.loadedam login:
Starting Hardware abstraction layer hald
eth0: Atmel MACB at 0x
Creating Dropbear SSH server RSA host
key.
Will output 1024 bit rsa secret key to '/etc/dropbear/
dropbear_rsa_host_key'
eth0: attached PHY driver [Generic PHY] (mii_bus:phy_addr3D%ffffffff:00,
i

modprobe: FATAL: Could not load /lib/modules/2.6.27/modules.dep: No
such file or
 directory

dropbear.
Starting syslogd/klogd: done
 * Starting Avahi mDNS/DNS-SD Daemon: avahi-daemon
[ ok ]
Starting GPE display manager: gpe-dm

.-------.
|       |                  .-.
|   |   |-----.-----.-----.| |   .----..-----.-----.
|       |     | __  |  ---'| '--.|  .-'|     |     |
|   |   |  |  |     |---  ||  --'|  |  |  '  | | | |
'---'---'--'--'--.  |-----''----''--'  '-----'-'-'-'
                -'  |
                '---'

The Angstrom Distribution at91sam9263ek ttyS0

Angstrom 2009.X-test-20091217 at91sam9263ek ttyS0

at91sam9263ek login:



Re: No graphic when loading "x11-gpe-image" for AT91SAM9263
Hi,

Have you tried starting gpe-dm manually from the shell?
Any error dumps?
What X server are you using (xorg/kdrive) ?
Do you see the framebuffer device in /dev ?

regards,
sasho

Re: No graphic when loading "x11-gpe-image" for AT91SAM9263
nit ha scritto, Il 29/12/2009 11:30:
Quoted text here. Click to load it

For a more recent version of OpenEmbedded based system, I would suggest
you to test with KaeilOS distribution onstead of Angstrom
Simply follow these instructions
http://www.kaeilos.com/?q=download

Happy hacking ;-)

--
helix

Site Timeline