Error in porting a running Http Application to uClinux-2.0.38

Do you have a question? Post it now! No Registration Necessary

Translate This Thread From English to

Threaded View
Hi All,

    I have an http Client program which is to fetch an
 mp3 file from an apache server.The program works fine
on the Linux Platform-kernel 2.4.18,when it is made to
transfer an mp3 from a machine having "httpd"
running.But when the application is ported to the
Board after using gcc optimizations for the board.The
program runs but does not fetch the file.I FORGOT TO
TELL YOU THAT THIS PROJECT WAS DONE TILL THIS LEVEL BY
ANOTHER PERSON,HE HAS LEFT THE COMPANY.I have been
given this project to Qualify for joining the Company
as a permanent Employee.The programmer had used static
arrays in the program except 3 char pointers.One of
these pointers is malloc-ed for (char *)1460
bytes.This pointer is used for building the request to
the Apache server.When this request Line is fully
built with the 0xd and 0xa to specify the end of the
request string I found a dump of the following strings
on the telnet screen

"status==GCONV_INPUT_FULL||status==GCONV_INPUT_EMPTY||......."along
with the request string.The above mentioned code
snippet is not in the program file.But these strings
could be could be there in one of the dependency
rw.c,ioctl.c and some other .c files in the Makefile.

If you can please let me know the dependencies I would
need to get this program running on the NET+ARM.


when this request is send to the Apache server ,The
Apache server responds saying that there is a Request
Error.

Pls let me know what u feel about this error and how
to fix it.Is there a network byte order problem.I have
been able to ftp the binaries into the board and they
work fine.So is there a network byte ordering
problem.If there is how do I fix it.Thanks.

George.

Re: Error in porting a running Http Application to uClinux-2.0.38
Hi All,

    I have an http Client program which is to fetch an
 mp3 file from an apache server.The program works fine
on the Linux Platform-kernel 2.4.18,when it is made to
transfer an mp3 from a machine having "httpd"
running.But when the application is ported to the
Board after using gcc optimizations for the board.The
program runs but does not fetch the file.I FORGOT TO
TELL YOU THAT THIS PROJECT WAS DONE TILL THIS LEVEL BY
ANOTHER PERSON,HE HAS LEFT THE COMPANY.I have been
given this project to Qualify for joining the Company
as a permanent Employee.The programmer had used static
arrays in the program except 3 char pointers.One of
these pointers is malloc-ed for (char *)1460
bytes.This pointer is used for building the request to
the Apache server.When this request Line is fully
built with the 0xd and 0xa to specify the end of the
request string I found a dump of the following strings
on the telnet screen

"status==GCONV_INPUT_FULL||status==GCONV_INPUT_EMPTY||......."along
with the request string.The above mentioned code
snippet is not in the program file.But these strings
could be could be there in one of the dependency
rw.c,ioctl.c and some other .c files in the Makefile.

If you can please let me know the dependencies I would
need to get this program running on the NET+ARM.


when this request is send to the Apache server ,The
Apache server responds saying that there is a Request
Error.

Pls let me know what u feel about this error and how
to fix it.Is there a network byte order problem.I have
been able to ftp the binaries into the board and they
work fine.So is there a network byte ordering
problem.If there is how do I fix it.Thanks.

George.

Site Timeline