Flyback supply regulation problem

Hi to all. I'm having a problem getting a flyback supply to regulate properly. (From no load to full load) The supply is designed around a NCP1207 QR converter. The feedback circuit is a standard TL431 shunt regulator connected to an Opto. The "opto's transistor collector" is connected to the feedback pin (pin 2) of the 1207 controller chip.Pretty much exactly as shown in the data sheet(fig 1). Most of the app notes use a similar arrangement. If I use a tl431 from Integral semiconductor(Korea) the supply regulates very well. If I use a tl431 from say Texas , the regulation is not so great. On- semi is even worse :0( Does anyone have any experience with this problem , and if so how to improve things. We could use the part from Integral , but I don't want to be tied to one supplier ,especially for a "jelly bean" part like this. Just out of interest , using this same type of feedback cct in my flyback supply designed around a uc3842 controller chip does not have the same problem. On this chip , you can set the error amplifier gain externally and this seems to overcome the problem. The 1207 chip does not offer you this option.

As I said , any ides appreciated.

Cheers Rob

I'll try and post the output section below. The transistor is actually a TL431(aacircuit did not have a Tl431 :0) ) Use fixed font.

___ -. ,- ->|-----------o-'-UUU- ----o---'--------- )|( | | | | )|( | | | | -' '- --- | | --- | --- | | --- | | | | | | | | | | | '-----)------------)---' | | | | | | | | | | .-. .-. | | | | | | | | | | | '-' '-' | | | | | | | opto V -> .---o | diode - | | | | | | | | | .-. | \\| | | | | tl431 |------' | | |

Reply to
neddie
Loading thread data ...

=A0 |

=A0 |

--
> =A0 =A0 =A0 =A0 =A0| =A0 =A0 =A0 =A0--- =A0 =A0| =A0 =A0 =A0 =A0 =A0 =A0|=
 =A0---
 Click to see the full signature
Reply to
neddie

ElectronDepot website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.