ISE8.1 on OpenSUSE 64bit

Do you have a question? Post it now! No Registration Necessary

Translate This Thread From English to

Threaded View
Hi *,

just installed ISE8.1 with SP3 on a 64bit Linux-machine running OpenSUSE
10. Just thought I'd give it a try, even if it's not officially
supported by Xilinx and I haven't read any reports here on people
getting it to run successfully (BTW, ISE8.1 works fine on other machines
running OpenSUSE, but this is the first 64bit-machine I've tried).

Anyhow, most of it seems to work fine. The system is detected correctly
as lin64, the GUI works, and the utilities for flow work all right
(meaning XST, ngdbuild, map and so on don't crash and seem to do what
they should). The only thing that does not work is par. Starts up all
right, it reads in the constraints and displays device utilization, but
then exits with a fatal error before it starts placing:

"Starting Placer
FATAL_ERROR:PersonalityModule:baspmdlm.c:164:1.25 - dll library
<PlXil_Legal> does not exist. Process will terminate.
To resolve this error, please consult the Answers Database and other
online resources at http://support.xilinx.com .
If you need further assistance, please open a Webcase by clicking on the
"WebCase" link at http://support.xilinx.com "

There's nothing on this on the support website. I've opened a web case,
but since OpenSUSE is not a supported platform, they probably won't be
able to help there.

Has anyone else seen this? "Xil_Legal" strikes me as kind of an odd name
for a library. It doesn't exist anywhere in the installation
directories, but it's not there on other machines running OpenSUSE
either, and on those machines the tools work fine.

Has anyone gotten this to work?

cu,
Sean

Re: ISE8.1 on OpenSUSE 64bit
FWIW, my ISE8.1 installation has libPlXil_Legal.so in
$XILINX/xilinx/bin/lin64 on my RedHat EL3 64-bit machine.

Jim
http://home.comcast.net/~jimwu88/tools /


Sean Durkin wrote:
Quoted text here. Click to load it


Re: ISE8.1 on OpenSUSE 64bit
Quoted text here. Click to load it
Strange... It's not there on my machine... I'll do a reinstall tomorrow,
maybe it'll show up...

cu,
Sean

Re: ISE8.1 on OpenSUSE 64bit
Quoted text here. Click to load it

Tried again just now, no luck, no libPlXil_Legal.so anywhere. Strange
thing is, it's not there on any other machine either. I have ISE8.1
installed on several Windows and Linux machines, none of the
installations has a libPlXil_Legal.so/libPlXil_Legal.dll, but they all
work fine, except the one on the 64bit-machine.

cu,
Sean

Re: ISE8.1 on OpenSUSE 64bit

Quoted text here. Click to load it

I don't know why they all work w/o this file. I just checked my other
installations (WinXP, and FC3 32-bit) and they all have this file.

Windows: in $XILINX\xilinx\bin\nt
FC3 32-bit: $XILINX/bin/lin/


Re: ISE8.1 on OpenSUSE 64bit
Quoted text here. Click to load it

I don't know why they all work w/o this file. I just checked my other
installations (WinXP, and FC3 32-bit) and they all have this file.

Windows: in $XILINX\xilinx\bin\nt
FC3 32-bit: $XILINX/bin/lin/

Jim
http://home.comcast.net/~jimwu88/tools /


Re: ISE8.1 on OpenSUSE 64bit => ISE8.2 works
In case anyone's interested: I just installed ISE8.2, and that works
fine with OpenSUSE 64bit.

Sean Durkin wrote
Quoted text here. Click to load it


Re: ISE8.1 on OpenSUSE 64bit => ISE8.2 works
FYI:
ISE8.1 SP3 works without problems on Fedora Core 5 64bit  (P4 650
3.4GHz)


Site Timeline