Help about Cogent CSB637 Board.

Do you have a question? Post it now! No Registration Necessary

Translate This Thread From English to

Hi Everyone,
 
I am working with Cogent CSB637 Board for last 2 weeks.But I am Stuck a
one point. I am trying to Port Linux on it. I took latest patches from
maxim.org.za/AT91RM9200/2.6/  and  maxim.org.za/AT91RM9200/ . I applie
them on kernels (2.4 /2.6). Then I configure the kernel with
 
make ARCH=arm CROSS_COMPILE=arm-linux- xconfig
 
In configuration I am enabling general features only. I have enable
Serial Console Support for AT91RM9200.Since I am viewing my output o
Hyperterminal.
 
and compiled the kernel with
 
make ARCH=arm CROSS_COMPILE=arm-linux- zImage
 
then I send the zImage created by it to my board. then i run this imag
with this command
 
startlinux
 
which is a shell script (which is correct).
 
Then the problem begins.My kernel shows
 

Uncompressing Linux.................................................
done, booting the kernel.
 
Then nothing happens.I have tried many kernels and many patches but th
problem is same.But when I use kernel given at at91rm.com. It goes littl
further and shows
 
"kmod: failed to exec /sbin/modprobe -s -k block-major-31, errno = 2    
                                                          
VFS: Cannot open root device "1f                              
Please append a correct "root=" boot option                              
          
Kernel panic: VFS: Unable to mount root fs on 1f:04
"
Can anyone tell me what is wrong in my steps.
 
I have another problem. If I successfully booted the linux . What abou
the file system (like  /bin /proc /sbin). How it will be created? what
the steps to create it? Please guide in this issue.
 
Please forward all your suggessions to gaurav snipped-for-privacy@yahoo.com.
Waiting for your reply.
Bye.
 
Regards,
Gaurav Sarode.



Site Timeline