L5973D - problem - pali się

Do you have a question? Post it now! No Registration Necessary

Translate This Thread From Polish to

Threaded View
Witam,

Mam problem ze stabilizatorem L5973D. Aplikacja jest dość specyficzna,  
bo stabilizator ten stabilizuje napięcie, które trafia na driver MOSFETa  
(obniża z 20V do 12V) jednego z tranzystorów w mostku H, pracującym z  
napięciem 800V po stronie DC.

Okazuje się, że raz na jakiś czas (kilkaset godzin pracy), układ ulega  
uszkodzeniu. Zazwyczaj pali się obudowa do tego stopnia, że zostają same  
nóżki scalaka... Nic w jego otoczeniu nie ulega uszkodzeniu.

Czy ktoś z kolegów przerabiał taki problem? Póki co jest taka poszlaka,  
że nóżka INHIBIT w stanach przejściowych układu może być polaryzowana  
napięciem poniżej GND (być może więcej niż -0,3V, co wykracza poza  
specyfikację...)


Pozdrawiam,
Krzysiek

Re: L5973D - problem - pali się
On 04.01.2013 23:37, Krzysztof wrote:
Quoted text here. Click to load it

Całkiem prawdopodobne - zatrzaskuje się jakiś tranzystor pasożytniczy i  
przewodzi do upalenia struktury. Daj schottky'ego do masy i zobacz, czy  
pomoże.


--  
Pozdrawiam
Michoo

Re: L5973D - problem - pali się

Quoted text here. Click to load it

Problemem mogą być zakłócenia. Duże dv/dt.

Pozdrawiam
K.S.  


Re: L5973D - problem - pali się
W dniu 2013-01-05 00:26, Michoo pisze:> On 04.01.2013 23:37, Krzysztof  
wrote:
 >> Póki co jest taka poszlaka,
 >> że nóżka INHIBIT w stanach przejściowych układu może być polaryzowana
 >> napięciem poniżej GND (być może więcej niż -0,3V, co wykracza poza
 >> specyfikację...)
 >
 > Całkiem prawdopodobne - zatrzaskuje się jakiś tranzystor pasożytniczy  
 > i przewodzi do upalenia struktury. Daj schottky'ego do masy i zobacz,  
 > czy pomoże.

No tak, ale usterka zdarza się raz na kilkaset godzin pracy... Trudno  
będzie zweryfikować taką poprawkę, czasami (przypuszczam, że zależy od  
egzemplarza) L5973D nigdy się nie psuje.


Pozdrawiam,
Krzysiek


Re: L5973D - problem - pali się
W dniu 2013-01-05 11:17, Krzysztof pisze:
Quoted text here. Click to load it

Nie pokazałeś schematu, pcb i dziwisz się, że dostajesz odpowiedzi ze
szklanej kuli?





Re: L5973D - problem - pali się
 > W dniu 2013-01-05 11:36, Zbych pisze:
 > Nie pokazałeś schematu, pcb i dziwisz się, że dostajesz odpowiedzi ze
 > szklanej kuli?

Szukam raczej nowej niezależnej koncepcji, świeżego spojrzenia, a nie  
super dokładnego rozwiązania...

Układ (i jeszcze bliźniacze obwody stabilizatora) pracują w  
specjalizowanym zasilaczu AC/DC o mocy 16 kW. Poziom zakłóceń jest bez  
wątpienia spory. Układ pracuje w klasycznej aplikacji dla układu L5973D  
(jak z noty katalogowej).


Pozdrawiam,
Krzysiek

Re: L5973D - problem - pali się
On 05.01.2013 11:17, Krzysztof wrote:
Quoted text here. Click to load it

Moje /dev/glassorb więcej nie wypluwa. Objawy wskazują, że może być to  
latchup: http://en.wikipedia.org/wiki/Latchup

Ja kiedyś strzeliłem stabilizatorem po pokoju po tym jak dokumentacji  
przeczytałem "may latchup" jako "dotyczy to rzadkiego przypadku w  
produkcji a nie pojedynczego prototypu".

--  
Pozdrawiam
Michoo

Site Timeline