Retroeclairage afficheur controlpod Logitech Z5450

Do you have a question? Post it now! No Registration Necessary

Translate This Thread From French to

Threaded View
Salut,

J'ai un ensemble 5.1 Z5450 de cgez Logitech qui dispose d'un control pod
dont le rC3%A9troC3%A9clairage de l'afficheur a rendu l'C3%A2me.
(Enfin, c'est ce que j'en conclu, vu qu'il y a quelque chose d'affichC3%A9
mais c'est illisible si on n'a pas le nez dessus).

En revanche, je ne sais pas si C3%A7a vient de l'afficheur lui mC3%AAme o=
u de la
carte sur lequel il est raccordC3%A9.
Par ailleurs, cet afficheur ne me semble pas standard : C'est un 2*20
caractC3%A8res mais il dispose de 8 pins.
Je n'arrive pas C3%A0 trouver de datasheet correspondant C3%A0 ce type
d'afficheur.

J'ai bien un afficheur 2*20 dans mes tiroirs mais avec 16 pins
(interface HD44780).

Quelques photos :
http://pix.toile-libre.org/upload/original/1331997482.jpg
http://pix.toile-libre.org/upload/original/1331996407.jpg
http://pix.toile-libre.org/upload/original/1331996517.jpg

Auriez-vous une piste pour rC3%A9parer cela ?
Au moins, dans un premier temps, pouvoir identifier les broches de
l'afficheur et savoir si C3%A7a vient de lui ou pas.

Merci,
LoC3%AFc


Re: Retroeclairage afficheur controlpod Logitech Z5450

1331998658.2047.10.camel@lorentz...
Salut,

J'ai un ensemble 5.1 Z5450 de cgez Logitech qui dispose d'un control pod
dont le rétroéclairage de l'afficheur a rendu l'âme.
(Enfin, c'est ce que j'en conclu, vu qu'il y a quelque chose d'affiché
mais c'est illisible si on n'a pas le nez dessus).

En revanche, je ne sais pas si ça vient de l'afficheur lui même ou de la
carte sur lequel il est raccordé.
Par ailleurs, cet afficheur ne me semble pas standard : C'est un 2*20
caractères mais il dispose de 8 pins.
Je n'arrive pas à trouver de datasheet correspondant à ce type
d'afficheur.

J'ai bien un afficheur 2*20 dans mes tiroirs mais avec 16 pins
(interface HD44780).

Quelques photos :
http://pix.toile-libre.org/upload/original/1331997482.jpg
http://pix.toile-libre.org/upload/original/1331996407.jpg
http://pix.toile-libre.org/upload/original/1331996517.jpg

Auriez-vous une piste pour réparer cela ?
Au moins, dans un premier temps, pouvoir identifier les broches de
l'afficheur et savoir si ça vient de lui ou pas.
==========
Il s'agit probablement  d'un afficheur à commande série  vérifie les deux
bornes d'alimentations  et  la borne de réglage du contraste (zéro =>  vcc )
En règle générale  il y a deux bornes ( K.A)  pour alimenter l'eclairage ,
les deux dernières bornes 7-8,  vérifie si elles sont alimentées  , auquel
cas la led  est grillée , avec un peu de dextérité et de prudence elle peut
etre changée .



Re: Retroeclairage afficheur controlpod Logitech Z5450
Le samedi 17 mars 2012 C3%A0 19:14 +0100, Maior a C3%A9crit :
Quoted text here. Click to load it

-1,7V entre 7 et 8
Mais es-tu sC3%BBr que ces bornes sont utilisC3%A9es pour le rC3%A9tro-=
C3%A9clairage ?
(Tu connais l'adressage des autres bornes ?).

Par contre, si la led est accessible, je devrais pouvoir mesurer la
tension directement C3%A0 ses bornes. Je vais voir C3%A7a ...


Re: Retroeclairage afficheur controlpod Logitech Z5450
Le samedi 17 mars 2012 C3%A0 20:19 +0100, LoC3%AFc GRENON a C3%A9crit :
Quoted text here. Click to load it

Bon, j'ai pu accC3%A9der aux leds, il y en a 6 en tout (3 de chaque cotC3%
A9%).
J'ai pu vC3%A9rifier la continuitC3%A9, C3%A7a va bien aux broches 7 et =
8.

En envoyant 5 V sur ces broches, le rC3%A9troC3%A9clairage fonctionne (ho=
rmis 2
leds, mais c'est pas bien grave).

Donc maintenant, je sais que le soucis est sur la carte et non pas
l'afficheur. C'est ce que je craignais :(


Re: Retroeclairage afficheur controlpod Logitech Z5450

1332011952.2047.15.camel@lorentz...
Le samedi 17 mars 2012 à 19:14 +0100, Maior a écrit :
Quoted text here. Click to load it

-1,7V entre 7 et 8
Mais es-tu sûr que ces bornes sont utilisées pour le rétro-éclairage ?
(Tu connais l'adressage des autres bornes ?).

Par contre, si la led est accessible, je devrais pouvoir mesurer la
tension directement à ses bornes. Je vais voir ça ...
==============
Sûr non évidement , mais .. j'ai  ce type de LCD  série  synchrone  Ã  8 PIN
1:Vss  2: Vdd  3:CS   4:SID (input)  5:CLK   6:SOD(output)  7:Anode
8:Kathode.  (au fait ... pas de réglage de contraste à cause du type  (STN
 transflective) )
Par contre, tu ne peux pas te tromper  en recherchant Vdd  Vss
 + 1.7 volts pour l'alimentation de la led d'éclairage parait  correct





Re: Retroeclairage afficheur controlpod Logitech Z5450

4f64ed64$0$12515$ snipped-for-privacy@reader.news.orange.fr...
Quoted text here. Click to load it
==========
après ton dernier message c'est bien ce type,  apparemment donc les leds
seraient connectées  en paralléle
Bonne soirée



Re: Retroeclairage afficheur controlpod Logitech Z5450
Le samedi 17 mars 2012 C3%A0 21:02 +0100, Maior a C3%A9crit :
Quoted text here. Click to load it

Yep, mais vu que C3%A7a s'allume sous 5V, les 1.7V que je mesure seraient
trop faibles, non ?
Par contre, comme il y a plein de colle sur la carte, C3%A7a ne m'aide pas
pour retrouver oC3%B9 les broches y sont connectC3%A9es ...
Y'a un moyen de virer cette colle sans risquer de tout abimer ?


Re: Retroeclairage afficheur controlpod Logitech Z5450
Le samedi 17 mars 2012 C3%A0 21:40 +0100, LoC3%AFc GRENON a C3%A9crit :
Quoted text here. Click to load it
A9%tro-C3%A9clairage ?
Quoted text here. Click to load it

La cathode du rC3%A9tro-C3%A9clairage vient de ce composant C3%A0 droite=
 :
http://pix.toile-libre.org/upload/original/1332025367.jpg

Je lis donc 13W 76 ou 13W 7G.
En recherchant la correspondance du C2%AB SMD code C2%BB, je trouve ceci =
:
http://www.s-manuals.com/smd/13 mais une zener de 36V, C3%A7a me parait
C3%A9norme ...
Vous avez une idC3%A9e de ce qu'est ce composant ?


Re: Retroeclairage afficheur controlpod Logitech Z5450
Le dimanche 18 mars 2012 C3%A0 00:06 +0100, LoC3%AFc GRENON a C3%A9crit =
:
Quoted text here. Click to load it

Hum, personne ?


Re: Retroeclairage afficheur controlpod Logitech Z5450
On 24 mar, 21:42, LoEF%c GRENON :

Quoted text here. Click to load it

Sur la photo, ca c'est le composant E0% gauche, pas E0% droite.

Quoted text here. Click to load it

Pas forcE9%ment, vu la taille du composant c'est la puissance
qui doit EA%tre limitE9%e, mais la tension *peut* EA%tre de 36 V ...

Quoted text here. Click to load it

A 3 pattes ce serait plutF4%t un transistor, non ?
(quoique ce boitier est aussi utilisE9% pour des diodes)

Quoted text here. Click to load it

Re: Retroeclairage afficheur controlpod Logitech Z5450
Le samedi 24 mars 2012 C3%A0 14:03 -0700, Jean-Christophe a C3%A9crit :
Quoted text here. Click to load it

Effectivement :)

Quoted text here. Click to load it

C3%87a me parait C3%A9norme par rapport C3%A0 l'application, en fait. Pa=
s par
rapport au boitier.

Quoted text here. Click to load it

Ben, peut-C3%AAtre mais comment le savoir de maniC3%A8re sC3%BBre et ret=
rouver ses
caractC3%A9ristiques ?
Ce que j'ai trouvC3%A9 me mC3%AAme C3%A0 C3%A7a :
http://www.s-manuals.com/smd-files/pdf/c/cmszda_c.pdf
Deux diodes zeners 36V C3%A0 anode commune20%


Re: Retroeclairage afficheur controlpod Logitech Z5450

1332016815.2047.20.camel@lorentz...

Yep, mais vu que ça s'allume sous 5V, les 1.7V que je mesure seraient
trop faibles, non ?
Par contre, comme il y a plein de colle sur la carte, ça ne m'aide pas
pour retrouver où les broches y sont connectées ...
Y'a un moyen de virer cette colle sans risquer de tout abimer ?
===========
La chute de tension d'un led (ou la tension à ses bornes mesurée entre coté
positif et l'autre borne )  varie  de 1.6 à 3.6 v en fonction du type,
c'est pourquoi,  1.7 volts  ne serait pas anormal,
( Si elles sont connectées en parallèle , la chute de tension est identique
,  lorsqu'une diode est grillée, la luminosité des autres est plus intense )
Maintenant , elles peuvent etre connectées  chacune indépendamment avec leur
propre résistance de limitation de courant , c'et pourquoi le seul
diagnostique pratique est la mesure de la chute tension, et le remplacement
si elle n'est pas allumée alors que la tension d'alimentation est présente à
ses bornes .

Effectivement , très délicat à manipuler , avec une pointe fine on peut
toujours , à  travers le vernis isolant  faire des mesures au plus près du
composant , mais il est exclu évidement de démonter quoi que ce soit , sauf
pour  dessouder l'écran  et le remplacer




Site Timeline