Støj ??

Do you have a question? Post it now! No Registration Necessary

Translate This Thread From Danish to

Threaded View
Hej

Jeg har et lidt underligt fanomen jeg ikke helt kan forklare andet end
ringninger, men syntes ikke jeg kan se det....

JEg leger med at forbinde en PHY til et FPGA board, PHY'en har mangement
MDIO MDC interface...

Det er meget lign I2C/SPI

en clk og en fælles I/O... PT kører jeg 200 Khz

Jeg har ca 10Cm fladkabel mellem de 2 print.


Det kører ikke før jeg har en 800-1K modstand i serie med CLK'en...
Det eneste der sker er faktsik det ligner den mister en clk puls..
spædningen er 3.3V

Er det normalt allerede ved 200Khz at man skal have et rc led på for at
dæmpe ringninger, eller hvad går der galt ?
Umilbart er der ikke meget forskel at se på clk'en når det virker og ikke
virker
Er jeg nød til at ligge en serie modstand i serie med alle I/O mon ?

PHY = RTL8201L
FPGA = SPARTAN3

Kasper



Re: Støj ??
Quoted text here. Click to load it

Det er ikke frekvensen det er vigtig det er flanke stejlheden, IO'er på
SPARTAN3 har programmerbar slewrate og drive strenght, prøv at lege lidt
med det (kan gøres i UCF filen)

Det sku' i alle tilfælde ikke være nødvendigt med seriemodstande på alle IO, ved
de lave
hastigheder er det klokken og lign. der har et problem med ringing
fordi det er flanker der er interessante, data signals sku' gerne være faldet
til ro længe inden de skal bruges ...

-Lasse


Re: Støj ??
Quoted text here. Click to load it


Tak for dit svar :)

Jeg må sige jeg har løst problemet og hørt dine svar fra anden side :)

Jeg har fået boardet til at registrere den har modtaget en pakke etc,
fjumler lige rundt med lidt ram interface PT inden jeg skal have sendt en
pakke...

Problemet var bla en defekt jumper der vælger om udgangs forsyningen skal
være 3/5V og  jea *flovt* så havde jeg fået lavet UCF filen efter et gammel
diagram så der var byttet ben :(.. intet brændte af :)

Kasper



Site Timeline