Reperationsforslag til Agilent 34401A DMM

Do you have a question? Post it now! No Registration Necessary

Translate This Thread From Danish to

Threaded View
Hej.

Jeg er igang med at reppe et Agilent 34401A DMM der er blevet brændt af
i indgangen. Tror at det fjols har smidt adskillige KV ind i Ohm
indstillingen, en del var futtet af i Current source, og lidt opamps
hist og her.

Jeg har skiftet ALT hvad der kan kravle og gå af Opamps og en hundedyr
custom analog switch kreds i det, og nu er jeg nede fra et hav af fejl i
selvtesten til 2 fejl.

Den fejler med disse to tests:

621    AC rms full scale failed    This test configures for the 100 mV ac
range. The 1 mA ohms current source is switched on to charge the ac
input capacitor C301. This produces a pulse on the output of the rms-to-dc
converter which is sampled 100 ms after the current is applied. A 20 ms
A/D measurement is performed and checked against a limit of 10 V ± 8 V
into the ADC.

og

622    Frequency counter failed    This test configures for the 100 mV ac
range. This test immediately follows test 621. With C301 holding a
charge from test 621 the ac input is now switched to ground with K103.
This produces a positive pulse on the input to the frequency comparator
U310A. While C301 discharges, the ENAB FREQ bit is toggled four times to
produce a frequency input to the counter logic in U501. A failure occurs
if the counter can not measure the frequency input.

Fejl 622 er oplagt, hvis den er "døv" det område som der testes i, i
621, så fejler 622 også.

Diagram med AC-delen kan ses her:

http://zapro.dk/public/misc/AC%20Circuit.pdf

Jeg har skiftet de analoge switches der ses i diagrammet (U304/306) samt
opamps.

Fejlen ligger i attenuatoren. Hvis jeg tilslutter ca. 11 volt AC (det er
hvad min halogenlampe på bordet giver) så måler jeg dette i de 5 ranges
som instrumentet har (jeg har sat det på manuel range)

Range 1: 000,000 mVAC (Her bør det skrive 0VLD)
Range 2: 0,62890 VAC (Her bør det også skrive 0VLD)
Range 3: 07,5554 VAC (Her bør det skrive Ca. 11,000 VAC)
Range 4: 010,898 VAC (Dette er helt korrekt)
Range 5: 0010,89 VAC (Dette er helt korrekt)

Det skal lige siges, at jeg har lånt et instrument helt magen til, så
jeg "ved" hvad det bør sige i de forskellige indstillinger.

ALT går igennem selvtesten uden problemer og Current source virker også
perfekt efter udskiftning af diverse dele, så det må næsten være
Attenuatoren.

Når jeg sætter det til at måle VAC i autorange så "hænger" det fast, da
det som sagt måler forkert, og er helt "døv" i den laveste range...

Jeg undskylder det meget lange indlæg, men jeg er jo næsten nødt til at
forklare hvad det handler om, jeg er bare kørt død i den her reparation,
og jeg har set mig blind på den sidste fejl.

Der er smidt over 1000 kr i reservedele i instrumentet, så det ville
være surt at kassere det nu :-/

Den fulde service manual, kan for interesserede ses her:
http://zapro.dk/public/misc/34401-90013.pdf

// Per.


Re: Reperationsforslag til Agilent 34401A DMM

Quoted text here. Click to load it


Jeg ville kigge nærmere på modstande og især kondensatorer i
indgangstrinnet. (C301-C302)  ,hvis indgangen har fået sådan et skrald.

mvh
JBH



Re: Reperationsforslag til Agilent 34401A DMM
Quoted text here. Click to load it

Will do. Dog må C301 være ok, da den måler korrekt i de høje ranges. Den
er jo koblet ind i AC-kredsløbet altid.

Jeg kan bare ikke helt gennemskue kredsløbet, det er lidt indviklet.

Men kan det ske, at sådan en præcisions kondensator (formodentlig folie)
kan afbryde helt ? Den er jo 100 % døv i den laveste range.

// Per.

Re: Reperationsforslag til Agilent 34401A DMM

Quoted text here. Click to load it


Følg signalvejen og vurder hvilke modstande og kondensatorer som evt. kan
være skadet. En modstand kan sagtens være vokset/steget i værdi uden at den
fysisk ser skadet ud.  Kondensatorer kan være læk (især  keramiske hvis de
har fået overspænding)  foliekondensatorer skades ved overslag, men er ofte
selvhelende, dvs. kapaciteten falder en smule for hver gennemslag.  Hvis du
har måtte skifte op-amps, er "skraldet" jo nået noget ind i instrumentet og
måske fortsat rundt med forsyningsspændinger .


mvh
JBH



Re: Reperationsforslag til Agilent 34401A DMM
Quoted text here. Click to load it

Tabellen på side 100 (pdf side 106) viser "kontakternes" stilling.
Jeg tror der er byttet om på U306-B og U306-D i tabellen. Hvis det
er rigtigt så kunne det være forstærkeren U305-A der giver x100
forstærkning, og fejlen kunne være på en eller flere af: U304, U305,
U306, U102, eller R314.
mvh
Henning

Re: Reperationsforslag til Agilent 34401A DMM

Quoted text here. Click to load it

Jeg må kigge lidt mere på det. Idag er instrumentet mere defekt. Jeg har
smidt en variotrafo på idag, og uanset hvor meget spænding jeg pumper
ind, kan instrumentet ikke vise over 62 volt i alle ranges, pånær den
højeste (700V AC område) hvor instrumentet måler korrekt.

Så der må være noget i signalvejen der er smuttet.

Alle de analoge switche du ser i diagrammet, har jeg skiftet...

Jeg vil lige kigge på styresignalerne på de switches og sammenligne med
det instrument der virker.


// Per.

Re: Reperationsforslag til Agilent 34401A DMM
Quoted text here. Click to load it


Mere..
Prøv også at undersøge om signalerne fra U309/U311 der styrer
"kontakterne" skifter som de skal, især REG(11), REG(13), REG(15) og
REG(16) signalerne kunne fejle. Der kunne også være kortslutning på
R304 eller C304 og opamp U301-A dermed ikke forstærke x0.2

mvh
Henning.

Re: Reperationsforslag til Agilent 34401A DMM
Lidt nyt i sagen.

Jeg sad og målte på de switche der sidder i AC-delen, og fandt ud af, at
+5V floating var ca 4,22V, det var bestemt ikke rigtigt. Intet på dens
forsyning var unormalt varmt, så jeg startede med at tage de to
74HCT4094 (U309/U311) Og det gjorde ingen forskel.

Disse 2 kredse forsynes fra +5V floating igennem modstand R310 som er på
46 ohm. På den ene side målte jeg godt 4,90V (inden for specs) og ca
4,22 på den anden.

Tilbage sidder der to analoge switches som også forsynes igennem R310,
en DG411 og en DG211 (de er ens, DG411 har bare bedre specs, og er lidt
dyrere)

Jeg besluttede mig for at pille den DG211 af (U306) og så kom spændingen
op på 4,90V på begge sider af R310. Godt så. Jeg havde en spritny DG411
liggende, og da den er direct replacement for DG211 så lodder jeg den i.
Tænder, og igen er supply trukket ned til ca 4,20V - WTF?! - Hvad hulen
kan der være sket ?

Nogen idéer? Af hvad jeg kan læse ud af databladet på den har den bare 4
indgange, og 4 svævende switches, man burde ikke kun "overloade" den så
den klapper forsyningen sammen...

// Per.

Re: Reperationsforslag til Agilent 34401A DMM
Der var jeg vidst lige hurtig nok på aftrækkeren. Tror jeg har fundet
grunden til at U306 trækker forsynigen ned. min 15B forsyning er kun
1,16V, den burde være 15V...

15B forsyningen laves ud fra de +18V som er ok, igennem Zener CR306.

Tror lige jeg starter med at fjerne den Zener og se om den er ok...

// Per.

Re: Reperationsforslag til Agilent 34401A DMM
Tjek den her:

http://zapro.dk/public/misc/dead_zener.jpg

Det er CR306 med et krater i toppen.

// Per.

Re: Reperationsforslag til Agilent 34401A DMM
Så er jeg tilbage igen :-)

Listen over stumper jeg har skiftet er snart så lang, at jeg har holdt
op med at tælle.

CR304 og CR306 der står for at nedsætte +/-18V til +/-15V var begge
ødelagt. Jeg har til test smidt 5 1n4148 i hver position til test.

Nu kan instrumentet faktisk skrive 0VLD i alle ranges (jeg kan ikke
teste den øverste, da jeg ikke kan lave over 700VAC sådan "nemt")

Det er dog stadig stokdøvt på laveste range (100mVAC Range)

Jeg har nu testet alt, og har haft loddet alle kredse ud, og nu er der
kun de modstande og kondensatorer tilbage i signalvejen, de er bare så
svære at måle in-circuit, og det er noget rigtigt bøvl at lodde dem ud :-/

Men det fede er da, at alle ranges, pånær 100mVAC måler 100 % korrekt,
og er lineære :-)

Ja, grin bare over at jeg gider, men når man får foræret sådan et
instrument der er dødt, og ens fritidsinteresse er at reparere den
slags, så gør timelønnen ikke så meget :-)

// Per.

Re: Reperationsforslag til Agilent 34401A DMM
Quoted text here. Click to load it

På tabellen side 99 (pdf side 105) vises 2nd stage x100 valgt i
området 100mV. Det er det eneste AC Volt område med denne forstærkning
i 2nd stage. Fejlen kan derfor måske være at finde ved forstærkeren
U305-A. Med instrumentet i 100mV AC og med 100mV AC på indgangen bør
der være ca. 20mV på U304-C pin10 og 200mV på U306-C pin10.

mvh
Henning


Re: Reperationsforslag til Agilent 34401A DMM
Så passerer instrumentet selvtesten :-)

Trods megen inspektion finder jeg en dårlig lodning under en LF357 opamp
(U305) og da den er fikset, virker instrumentet :-)

Fantastisk!

Tak for hjælpen alle!!!

// Per.

Re: Reperationsforslag til Agilent 34401A DMM
Quoted text here. Click to load it

Så mangler du bare at få det kalibreret - og se om det overhoved måler
rigtigt, og overholder specs. efter den omgang ;-)

Peter



Site Timeline