Problem med TDA7240

Do you have a question? Post it now! No Registration Necessary

Translate This Thread From Danish to

Threaded View
Hej

Jeg har bygget denne forstærker

http://www.sandcastle.dk/artikler/AMP.gif

Diagrammet er sakset fra dette datablad

http://www.sandcastle.dk/artikler/TDA7240.pdf

Men den vil ikke starte, der er tilsyneladene
noget turn on delay der er styrret af signalet
på indgangen. Jeg kan bare ikke hitte ud af
hvordan det virker og om man kan slå det fra.
Der skal store signaler til at få den startet og
det duer simpelthen ikke. Det er på ben 2 det
styres, men som sagt jeg fatter det ikke.

Nogen hints derude ?

--
Mvh
Max



Re: Problem med TDA7240

Quoted text here. Click to load it

Ben 2 sætter forstærkeren i standby. Efter hvad jeg kan se, er der ikke
noget "turn on" system, der er afhængig af indgangssignalet. I flere
konstruktioner på nettet, er dette noget som folk selv bygger på.
Har du kontrolleret, at elektrolytten på ben 2 ikke er kortsluttet ?. Prøv
at løfte benet og se om der så kommer liv i dyret.
En så simpel konstruktion burde da virke. Men jeg har da før set simplere
ting drille på underlige måder.

Men der er da en del der har bygget forstærkere med denne kreds, så det
burde da fungere. Her er et komplet projekt med eagle diagram / print.
Næsten samme diagram som dit. http://www.a-netz.de/audioamp.en.php


M.v.h.

C. Nielsen




Re: Problem med TDA7240
Hej Carsten

Quoted text here. Click to load it


Som sagt virker den faktisk, men den skal have alt for
meget signal for at for at slå til. Jeg har prøvet med
både mindre og større kondensatore, uden det hjælper,
og fjerner jeg den, ja så bliver komstruktionen over-
følsom og brummer.

--
Mvh
Max



Re: Problem med TDA7240
Max udtrykte præcist:
Quoted text here. Click to load it

Som jeg læser den doc du refererer til, er det kondensatoren på ben 1,
der sætter turn on punktet, og på ben 2 turn on delay.
Anbefalet 1u for C1 - du har 22u i dit diagram.

Birger

--
http://varmeretter.dk - billig, sund og hurtig mad
http://bbsorensen.dk



Re: Problem med TDA7240
Birger Sørensen skrev:
Quoted text here. Click to load it

Og det er helt galt.
AC koplingen i indgangen, er den der styrer turn on.
Jeg kan forstille mig, det er den 220p du har til stel i indgangen, der
skaber problemet.

Birger

--
http://varmeretter.dk - billig, sund og hurtig mad
http://bbsorensen.dk



Re: Problem med TDA7240
Hej Birger

Quoted text here. Click to load it

Jeg har 1 uF på indgangen.

Quoted text here. Click to load it

Sjovt nok, men sætter man dc spænding på ben 1,2 eller 3,
ja så starten den op omgåenden, selv med meget lille signal,
men denne dc ødelægger så arbejdspunktet på den og kan
derfor ikke være der hele tiden.

Quoted text here. Click to load it

Ingen forskel om den er der eller ej.

--
Mvh
Max



Re: Problem med TDA7240
Den 17-07-2010 16:13, Max skrev:
Quoted text here. Click to load it

Den slaviske vej: Tjek alt, hver en komponent-værdi, hver forbindelse.

Man har før hørt om folk der bygget noget, hvor det så ikke er 100% det
samme som diagrammet. Du plejer ellers at have styr på det Max :-)

Når den spiller, virker mute så hvis du ligger benet til stell?

/Jan Rasmussen.

Re: Problem med TDA7240
Hej Jan

Quoted text here. Click to load it

Konstruktionen er jo til at overse, printet er simpelt, og jeg
har naturligvis checket. Jeg har ikke bare kikket på hvad der
står på komponenterne, jeg har også checket at det er korrekt.

Quoted text here. Click to load it

Ja, men ved de sidste to konstruktioner jeg har lavet, ja der har jeg
faktisk haft defekte IC'er i dem, sært når man tænker på hvor relativ
sjælden den slags fejl er. Jeg er begyndt at lure på om jeg har med
en batch af IC'er at gøre her som ikke lever op til specifikationerene.

Quoted text here. Click to load it


Ja, intet problem der.

--
Mvh
Max



Re: Problem med TDA7240
Quoted text here. Click to load it
har du købt den andet sted end du plejer?
eller måske har din forhandler fået fat i nogle fake-kredse...

vi har en underleverandør der simpelthen har fået et hel batch mikro
processorer der ikke virkede.. det viste sig dog at have en ret naturlig
forklaring i det der slet ikke var nogen die inde i plastic-pakken...

da der er stor komponentmangel i øjeblikket skulle markedet for fake
komponenter efter sigende også være markant stigende..

--
mvh
Rasmus



Re: Problem med TDA7240
Hej Rasmus

Quoted text here. Click to load it

Nej, købt samme sted som de andre defekte :)

Quoted text here. Click to load it

Det virker næsten mere som noget frasorteret, noget der
florere meget på dealer markedet.

Quoted text here. Click to load it

Ja, det er nok komponenter til at lave opstilling på P&P maskiner.

--
Mvh
Max



Re: Problem med TDA7240
Quoted text here. Click to load it

nope - eller det var i hvert fald ikke det de var købt som!

--
mvh
Rasmus



Re: Problem med TDA7240
Den 17-07-2010 18:31, Max skrev:

Quoted text here. Click to load it

Så holder jeg 10 øre på det er en defekt ic mere :-)


/Jan

Re: Problem med TDA7240
Hej Jan

Quoted text here. Click to load it


Det skulle så være to mere, jeg skal du lige understrege at de
andre IC'er jeg talte om ikke er TDA7540, men et stk NE567
og et stk ICL7660.

--
Mvh
Max



Re: Problem med TDA7240
Den 17-07-2010 23:48, Max skrev:

Quoted text here. Click to load it

Shit happens, havde du alle kredse på taget da det var torden den anden
dag? :-)

for ca 17kr + porto kan du få en ny at prøve med, fra den danske øst-blok.

http://www.el-supply.dk/?Gid=&VNr40%TDA7240

/Jan - excil-bornholmer.

Re: Problem med TDA7240

Quoted text here. Click to load it
Selvsving. Prøv at sætte et skop på højttalerklemmerne og se efter. Pas på
stel, da højttaleren svæver/er brokoblet - men det er du nok klar over.

Hilsen Sven



Re: Problem med TDA7240
Hej Sven

Quoted text here. Click to load it

Man behøver nu intet skop for at konstatere at der ikke er tale
om selvsving, den bruger nemlig praktisk talt ikke strøm når
den er tilsluttet, først når den er startet op. Men skopet bekræfter
nu også at der ingen selvsving er.

Quoted text here. Click to load it

Jeps, det er jo en brokoblet forstærker.

--
Mvh
Max



Re: Problem med TDA7240
Hej

Quoted text here. Click to load it

Nu har jeg så skiftet IC'erne ud med nogle med
en anden datokode, og så virker den som den
skal, så man må konstatere at jeg havde fået
nogle dårlige komponenter.

Men det er altså ikke til at se hvorfor de ikke
er som de skal være.

http://www.sandcastle.dk/artikler/TDA7240A.jpg

--
Mvh
Max



Re: Problem med TDA7240
Hej Max

Max skrev:
Quoted text here. Click to load it

Er skrifttypen og måden som datokoden er opbygget på, ikke anderledes på
de to defekte i forhold til den der virker?

Klon (dårlig kopi)?

Mvh Hauge

Re: Problem med TDA7240
Hej Hauge

Quoted text here. Click to load it

Ja, men hvad er den rigtige måde ?  :)

Quoted text here. Click to load it

Eller frasortering kan være en mulighed. Den slags
husere der en del af ude på dealer markedet.

--
Mvh
Max



Re: Problem med TDA7240
Quoted text here. Click to load it

jeg tror ikke ST har brugt silketryk de sidste 20 E5%r..
alex

Site Timeline