Motor i 3½" diskettedrev

Do you have a question? Post it now! No Registration Necessary

Translate This Thread From Danish to

Threaded View
Har nogen af jer prøvet at "lege" med sådan én på par.porten ?

Her er en link til en beskrivelse:
http://www.epanorama.net/circuits/diskstepper.html

Der er beskrevet i kabel - sådan:

Parallel port (25 pin)      Disk drive (34 pin)

   2 ------------------------- 20
   3 ------------------------- 18
                                       +--- 14
  20 ---------------------+--- 17
                                       +----19

Den skal selvfølgelig også have noget strøm f.eks. fra en
gammel pc-strømforsyning.

På ben 2 og 3 kan man bestemme omdrejningsretning
og give den pulser til bestemmelse af hastigheden, MEN
hvorfor rører den sig ikke ud af stedet ?

På linket beskrives også anvendelse af gamle harddiske
med et kabel med 34 ben - på mine diske er der 40 ben !

Hvordan kan man gøre det samme med 40 bens forbindelsen ?

Mvh KS




Re: Motor i 3½" diskettedrev

Quoted text here. Click to load it
Hej KS

Grunden til at han kun har 34 ben er, at han bruger nogle af de helt gamle
MFM harddiske.
Se sektionen som starter med: "In my experiments I have used ST506/412
interface hard disk drives. Those are the original IBM PC/AT hard disks
(usually called MFM disks) which needed a controlling card."
Her står også at de nyere harddiske er mere besværlige at arejde med, dels
fordi motor controleren er integreret på harddisken, dels fordi de bruger
Voice-coil systemer i stedet for step motorer.

/Tom



Re: Motor i 3½" diskettedrev
Quoted text here. Click to load it

Var det ikke til et floppydrev den angivne tegning var til?

m.v.h. Mikael


Re: Motor i 3½" diskettedrev
Quoted text here. Click to load it

Jow, men der var også et spørgsmål omkring 34/40 pols kablerne.

Men hvorfor virker det diskettekabel ikke ?
 - mangler der en leder eller hva' ?

Mvh KS



Re: Motor i 3½" diskettedrev
Quoted text here. Click to load it

Måske skal der være en disk i. Eller hovedet står på spor 0, har du prøvet
begge retninger? Prøv lige at hive ben 10 til stel, så skal spin-motoren
starte. Og lysdioden skal lyse, den tænder når man steller ben 14. Prøv lige
at stelle ben 12, hvis jumperen på drevet står til B-drev, er det ben 12 der
er drive-select.

Ellers bare 'stel løs' udgangene er open-collektor, så der sker ikke noget
ved at stelle samtlige ben.  :-)

--
Ulrik Smed
Aarhus, Denmark



Site Timeline