Gør en god gerning - hjælp en O pamp-spasser!

Do you have a question? Post it now! No Registration Necessary

Translate This Thread From Danish to

Threaded View
Hej!

Jeg sidder og er ved at flå hårene ud af hovedet, jeg kan ikke få det
til at passe.

Er ved at reparere et Agilent DMM hvor at spændingsreferencen er gået
fløjten.

Inden jeg nævner flere detaljer, så har jeg et kredsløb bygget over en
AD706JR opamp. Den har 15V forsyning, og ja, jeg har skiftet den, intet
ændrede sig.

I nørder der kan alle formlerne for opamps, kan du fortælle mig, hvad
spænding der skal være på TP1 i mit diagram, hvis opampen kører helt
uden load ?

http://www.zapro.dk/public/billeder/opamp/Opamp.png

På forhånd tak!

// Per.

Re: Gør en god gerning - hjælp en Opamp-spasser!
Quoted text here. Click to load it

Kig på:
http://www.csgnetwork.com/opampcalc.html

Vælg "non inverting"
Ra = R3 = 30K
Rf = R2 = 12,875K
V1 = 7000mV

Udgangsspænding = 10 volt

Klaus (der lige fik opfrisket sin opamp teori her)
--
 Modelbane Europas hjemmeside: http://www.modelbaneeuropa.hadsten.dk
   Modeltog, internet, gratis spambekæmpelse, elektronik og andet:
We've slightly trimmed the long signature. Click to see the full one.
Re: Gør en god gerning - hjælp en Opamp-spass er!
Per Jensen udtrykte præcist:
Quoted text here. Click to load it

7 / 30 x (30+12,875)
Op-Amp'en vil forsøge at få samme spænding på indgangene. For at der
skal være det, skal der være 7V mellem R2 og R3.
Tæt på 10V :-Z

Birger

--
http://varmeretter.dk - billig, sund og hurtig mad
http://bbsorensen.dk



Re: Gør en god gerning - hjælp en Opamp-spasser!


<KLIP>

GUD hvor er jeg glad for at have jer, i er sku hurtige!

Det vil sige at service manualen fra Agilent passer, så er der stadig
noget helt, helt galt.

Jeg har nemlig 1,7V på TP1 og jeg fatter det simpelthen ikke..

Jeg tør nu godt vise det hele diagram:

http://www.zapro.dk/public/billeder/opamp/159.pdf

U411 er fjernet for ikke at loade opampen.

U403 helt til venstre er sådan en lille spændingsref. modul fra Linear
Technology.

+10REF spændingen fra U400-A render til et andet sted på printet hvor at
det forsyner noget Current source til ohm måling, igennem en 14K7
modstand. Denne er fjernet.

Stadig, jeg har kun Ca. 1,7V på udgangen af U400-A

Jeg er ved at blive idiot!

Ja, alle modstandsværdier er tjekket

Nogle idéer ?

Det er et Agilent 34401a btw.

// Per.

Re: Gør en god gerning - hjælp enOpamp-spasser!
Quoted text here. Click to load it


Har du U400 i sokkel?

Ja = løft ben 5 (U400B sidder som 1:1 buffer for din 7 volt).
 
Quoted text here. Click to load it

Hvad spænding har du ud af den?

De 10 volt?
 
 
Quoted text here. Click to load it

Spændinger på ben 1, 2, 3, 4 og 8 tak.


Klaus
--
 Modelbane Europas hjemmeside: http://www.modelbaneeuropa.hadsten.dk
   Modeltog, internet, gratis spambekæmpelse, elektronik og andet:
We've slightly trimmed the long signature. Click to see the full one.
Re: Gør en god gerning - hjælp enOpamp-spasser!
Quoted text here. Click to load it

Nej SMD.

løft ben 5 (U400B sidder som 1:1 buffer for din 7 volt).


Jeg har meget forsigtigt løftet ben 5 og sat et stykke kaptop under som
isolering

Nu er der pludselig +10V på ben 1 !

Hvordan kan ben 5 loade den helt ned ? jeg forstår det altså ikke helt!

Quoted text here. Click to load it

Ca 7V som den er rated til at skulle levere.

Quoted text here. Click to load it

Nu ser U400A jo ud til at køre, nu hvor at ben 5 er løftet, men du får
da tallene alligevel:

1: 10.10
2: 7.07
3: 7.08
4: GND
8: 15.12 VCC

Jeg troede godt nok ikke at noget på U400-B kunne være skyld i at
overloade undgangen!

Jeg må igang med at finde synderen på +7REF spændingen så :-)

Quoted text here. Click to load it

Re: Gør en god gerning - hjælp enOpamp-spasser!
Quoted text here. Click to load it

Okay, så er der ikek noget i vejen emd din spændingsreferancer :-)
 
Quoted text here. Click to load it
 
Ohm mellem 5, 6, og 7 og til GND

Quoted text here. Click to load it

Mål ohm på udgangen.....
 
Quoted text here. Click to load it

Jeps, du roder - jeg går i seng :-)




Klaus
--
 Modelbane Europas hjemmeside: http://www.modelbaneeuropa.hadsten.dk
   Modeltog, internet, gratis spambekæmpelse, elektronik og andet:
We've slightly trimmed the long signature. Click to see the full one.
Rep af Agilent 34401a DMM
Hej gruppe.

Lidt update på min tråd vedr. opamp-forvirring i et DMM...

Jeg fik da spændings-referencen i orden nu, men listen over ting der er
defekte på det er snart alenlang.

Jeg fik det forærende af min arbejdsplads, Kalibreringsfirmaet sagde:
"Brændte printbaner, brændte transistorer & spoler"

Well det var "kun" 9 SMD transistorer, 2 SMD spoler og 5mm printbane
imellem to transistorer der var stegt i strømgeneratoren til Ohm måling,
så jeg skiftede bemeldte stumper, men det virker stadig ikke.

Jeg aner ikke hvad der er sket med instrumentet, men formoder at nogen
har ramt dets måleledninger med adskillige kilovolt...

Jeg har snart rykket rundt på opamps i eet væk og fundet et par opamps
der ihvertfald var stegt, samt en DG211 quad spst switch kreds i gain
selectoren.

Jeg kunne selvf. bestille en ny af hver opamp hos Farnell men det løber
skisme op.

Det skulle vel ikke være at en af jer faste kan sælge mig disse opamps,
alle i SO8 hus, til en liiidt anden pris en Farnell ? I så fald tager vi
den ovre i elektronikloesdele+maalegrej.

OP27
AD607
AD711
MC34081
LF356
LF357

Lige nu opfører instrumentet sig således:

Når jeg tænder det, så lyser ERROR ikonet i displayet, og kører jeg en
test i dets testmenu så fejler den med en error 604, som iflg.
servicemanualen er:

"A/D slope convergence failed The dc section is configured to the
measure zero state (MZ) in the 10 V range. This test checks whether the
ADC integrator produces nominally the same number of positive and
negative slope decisions (±10%) during a 20 ms interval. "


Kortslutter jeg indgangen på det viser det at der er spænding på
indgangen, åbner jeg den skriver den 0 mv. Samme med ohm måling, den
siger "OPEN" med terminalerne kortsluttet og Ca. 56 ohm når de er åbne.

Så noget inverterer måleresultatet, men jeg er sku løbet tør for opamps
nu...

Nogen reptips ?

// Per.

Site Timeline